NodeJS: File Download not working - returns empty query

Hey All,

I have a simple file download i’m trying to to get working in my NodeJS project but either i’m missing something, or its not working as it should be.

I’ve got a CSV file sitting in my folder in my project (public/exports/export_users.csv)
I have a new server connect file which just has the File Download step as per the instructions in the docs.
I’ve created a route and connected it to a anchor button in app connect.
All that happens is it opens up a new page to the server connect query, which is a blank page with

I’ve also tried this in a number of different ways. I.e. not using routes, but adding a server connect in my app and loading it on click (does nothing)

Tried the path without the public at the start, but it says ‘path not found’

Am i missing something?

I had this function working in a previous PHP project a while ago.

I tested it and can confirm that the file download doesn’t work in nodeJS. We will have it fixed in the upcoming update.

This has been fixed in Wappler 3.0.3

This topic was automatically closed after 47 hours. New replies are no longer allowed.