No uninstall option, and update notification fails when clicked

Wappler Version : All
Operating System : Ubuntu 20.04.4 (and previous versions)
Server Model: NA
Database Type: NA
Hosting Type: NA

What do you think should happen?

There should be an entry for Wappler in the Ubuntu Software area, there is none, so can’t uninstall (without using below solution*). Also, the update notification within Wappler fails to install the update when clicked.

Actual behaviour

Wappler has no uninstall option or entry the Ubuntu Software area. *The only way to uninstall is to click the installation file, and click uninstall. Further the update notification (within Wappler) when clicked downloads the update but fails to install.

How to reproduce

  • Open Wappler.
  • Click update. Update is downloaded but fails to install.
  • Open Ubuntu Software.
  • No Wappler entry is found.

Its not a hardship nor deemed urgent in my opinion, just a functionality issue, which can be worked around.

Thinking about it this is down to Snap, and could be rectified by submitting/publishing a Snap of Wappler…

What do you mean Dave? Does the inline updater show any error?


The file downloads successfully but upon installation the below error is displayed in the Ubuntu Software panel:

I think it is due to it not being a recognised Snap packaged application? Although having installed my own Electron applications they work just fine, so not entirely sure.

Dave, Wappler installer not a Snap based, so you can’t install it with Snap.

It is just a regular Debian installer.

So you can just install it by running it in the application installer or with the command: dpkg -I

Thanks George, yeah thought so. No problem there. Would be nice if the update notification installed though, is there a possible solution to that? Like I mentioned, it is not the most important thing and can be easily worked around. I think most Linux users are well adapt to working around most things, part and parcel of using Linux, comes with the territory. :slight_smile: