MySQL w/ ASP.NET

No matter what method I try, I am unable to connect to MySQL when server model is set to ASP.NET.

I am trying to connect to an AWS RDS MySQL instance.
I have a Windows 2012 server running IIS.
I have the project server model set to ASP.NET
I’ve tried Database Types of MySQL ODBC and ODBC System DSN.

I’ve tried on my Mac, using an FTP target, and then tried again by installing Wappler directly on the Web Server. I’ve also created both 64-bit and 32-bit versions of the system DSN.

I’ve also tried using ODBC driver versions from 3.5 to 5.3.

They all result in the same error as seen in the attached image.
“Error using this Database Connection! Server Response: Compilation Error”

Can you please advise?

I figured it out. I was deploying the Wappler project to a subdirectory of an existing ASP.NET web application. The existing web app was written in VB.NET, and Wappler exports dmxAppConnect, dmxConnect, and dmxConnections .aspx pages written in C#. VB.NET & C#.NET .aspx pages can’t both live under the same IIS web app. I ended up creating a new IIS directory/app and deployed the Wappler project there and now my MySQL connection is working.

1 Like

Yes you always need to make sure the Wappler site is deployed an IIS Application Root folder.

I’ve been able to connect to my ODBC data source and started building some pages. I tried adding a filter to my query but when I do it breaks the data connection completely. I’ve noticed in connection options that the ODBC System DSN is listed as a Microsoft Sql Server. If I change it to Microsoft Access and save it the setting does not save. The next time I look it is back to SQL

I realize that Access is outdated but I need to have my existing data functioning until I migrate.