MySql 8 or MariaDB 10.3.8 on Amazon AWS

#1

Hi Guys,

I need to use recursive CTE on one of my projects and it is only available on MySQL 8 and from MariaDB 10.2.2, so I created a database server on Amazon AWS, but I can’t connect to it from wappler.

The error message:
SQLSTATE[HY000] [2003] Can’t connect to MySql server on ‘server’ (111 - “connection refused”)

I can connect to the server using SQLyog or MySql Workbench, so it is only an issue from websites (including phpmyadmin…)

As far as I know MySql changed the default password encryption and since then it stopped working even on the newest php version.

Any of you had this problem before and have a workaround so I could use CTE queries on wappler?

Many thanks!

#2

Perhaps this link can help, seems you have to set authentication to mysql_native_password.

#3

Thanks Patrick! The default_authentication_plugin is mysql_native_password by default on Amazon RDS - Mysql8 (I assume because everyone had this issue), but still no luck. Since then I created a EC2 instance with Ubuntu and installed apache/php7.2/mysql8, then changed the configuration manually in the ini file but still get the same error message in wappler.

#4

By the way anyone could advise on the best php version for wappler and the required/recommended extensions on hosting? This is my setup right now:

#5

Ah found the issue… as didn’t have better idea, tried to upload the files to a different hosting server and connected to all instances succesfully. It seems some of the hosting providers blocking the connection to a 3rd party db servers.

2 Likes