Multiple repeats in server action error

I have a server action with several (nested) repeats in it. The repeats are linked to database queries.
Inside a repeat I have an insert or an update action .

But for some reason Wappler does not show the table fields anymore inside the repeat.
When I want to bind a field in the insert action and click the lightening icon I see a strange list of fields available inside the repeat: see screenshot:

it looks like a bug to me. Any suggestions?
I am on Mac osx, latest Wappler , mysql/php

I am sure you tried it, hit the refresh button. Also try recreate the server action (with a new name) and add one repeat at a time, to see when the issue appears

please check your output fields…


im having the same issue. but with query inside a condition inside a repeat
also the output doesn’t show in the browser debug after the first repeat.
does this happen to you also @oscreative

Yes I tried that. Also rebuild a new server action with same steps. It happens as soon as I place a nested repeat.
It gives the list as shown as above.

I also discovered weird mouse cursor behavior when hovering over that list. As soon as the cursor the second $index string, the hover background jumps back to the first $index string in the list.

@s.alpaslan: I tried all kind of options: with output and fields chosen, or without output, or with output but no fields chosen… it all gives the same outcome.

@mrbdrm : I have not tried this with a condition. I really haven’t much time to debug.

I hope @Patrick / @Teodor will have a look at it?

Hi @oscreative
Yes, we are checking this.

1 Like

that is because the formatter is listing the values from the previous repeat with the same name.
this happen on any place two elements with the same name shows (like variables)

1 Like