All of the sudden, after the last update and having recently moved over from Sockets to Resource Manager, my staging/testing environment can lo longer connect to the remote DB (A Linode Managed Database server) and gets this message:
no pg_hba.conf entry for host "IP ADDRESS", user "linpostgres", database "staging", SSL off
It was working a couple of days ago when i first switch over to Resource Manager.
I get the same message whether its me trying to connect to the DB in DB manager (uses my own IP) or if its the app trying connect (IP address of web server)
PLEASE NOTE: I have updated my ip address and the server IP address in the managed DB on Linode. ALSO, I can remotely connect to the DB through Navicat on my PC using the exact same host and login details (No SSL or SSH).
I dont think its an issue with the pg_hba file perse, as if it was I wouldn’t be able to remotely connect at all…but i easily can on Navicat or any other SQL admin GUI.
I have also completely deleted the staging web server and created a whole new target but the problem still remains.
Can anyone PLEASE help? I was wanting to push out an update this weekend but with my staging environment not working and now unusable, I certainly can’t touch anything on production.
Cheers!
FWIW, Windows 11, Node.JS, Docker, Resource Manager and Linode
Thanks for the reply Shalabh, it’s much appreciated.
I dont think its the ENV variables, something else is wrong here and i might raise a bug.
I started a whole new project and simply tried to add another custom DB connection (no ENV variables, no resource manager…simple new project + new DB connection)
If i enable SSL i get this error:
An error has occurred connecting to the database! write EPROTO 2264064:error:1000012e:SSL routines:OPENSSL_internal:KEY_USAGE_BIT_INCORRECT:..\..\third_party\boringssl\src\ssl\ssl_cert.cc:605:"
If i disable SSL i get the original error above:
no pg_hba.conf entry for host "103.51.113.10", user "linpostgres", database "postgres", SSL off
And again, if i was to use these same settings in Navicat i would connect perfectly.
Thanks @George I did see that, sadly have spent the better half of my Sunday troubleshooting this.
As a Managed Database i don’t have access to the pg_hba.conf file, and i guess i’ve been thrown off by the fact that i can still connect to the DB via Navicat or DB Visualizer…the problem is only in Wappler.
I have though spun up a free DB with Aiven and have been able to get Wappler to connect to that…So no back to seeing if it’s a Linode issue (that wasn’t there 2 days ago)
Also, i’ve now opened access to ALL IPs on Linode (0.0.0.0/0) and i still get the same error
Also @George I rolled back to version 5.8x and was able to connect to the remote DB within Wappler as per normal.
Updated back to 6.2.1 and tried the exact same DB connection and back to getting errors and unable to connect. Something doesn’t feel right here. I’ll log a bug