Localhost can load some pages but not others

Hi Wappler Community,

I am trying to streamline my development and deployment process, so my first steps have been making a new database identical to the one I have been using through DO and table plus. Then I will set my development target to point to this new database.

However, I’ve been running into an issue where some of my pages will load while others will give me the following error message below. My login page will load fine, although it doesn’t seem to be connected to my database as I can’t login. However, the page just beyond my login page comes up with an error.

Any solutions to this problem will be appreciated. I’m also looking for pointers on how best to streamline my development and deployment process. Thanks to everyone who has helped me thus far.

Still looking to resolve this issue if anyone has any ideas

From the error, I understand that you are using a DB connection with certificate.
And that certificate is missing when trying to connect to the DB.

Because you are seeing this on the page, and not on the network tab, I assume that this error is being originated from a server-side-SA/data that you might have on your content/layout page, which is calling some query.
Hope this gives you some idea on where to look.

1 Like

what do you mean by this?

I have an API that looks to see if the user “isloggedin” under app>server connect. When I remove these it will not load my pages but none of the data. I tried to login and here is what is says in regards to my API. I’m confused why it is struggling to reference my data here when my production target can just fine. Any help would be appreciated!

Are you sure you are not trying to connect to the production DB in Wappler.
There are some restrictions around that in the way Wappler works - based on your target and target type.

Maybe @George can help further, as I don’t use product type target, nor deploy from Wappler’s options

I see this “certificate” in the error message…

Maybe SSL is activated on your project but no SSL is defined/activated on his localhost?
Just saying…

I am currently connected to the same production database. I did however try to connect to a new database that I’ve created called discretedevdb, and I was getting the same error messages regardless. I believe it is because all of my API’s are connected to my production database.

Where would I go to see if this is the case?

can you share a screenshot of your Project_Options -->Targets–>Development(localhost) ?

I’ve tried wappler local, as well as docker, and found the most success with docker. Once I removed my isloggedin API I can now view all my pages, but the data isn’t loading even though it’s connected to my prod. database.

I see… It is a docker target.

I haven’t used docker so I can’t recommend something on this…
The reason I asked is because I saw the certificate on the error message. Is there a possibility that docker needs that or the reference to docker needs a secure layer.

Beside that, can you check if the isLoggedin api is redirecting or looking for a file in “https://…”

Ok I’ll look, thank you for your help thus far

Maybe it is related with the other post of yours about certificate that Apple and Cheese recommending you solutions?
Just saying…