Local MSSQL Instance

I have a local version of MSSQL running on my machine. I am not sure how to connect to it using Wappler. I have it set up for Windows Authentication and Server Authentication. I don’t see any way in the Target options to connect to this local instance.

The instance happens to be named the same as my machine and I can connect using SSMS to it using both Windows Authentication and my server authentication with username and password.

Can you explain how I would be able to specify this as my Database Connection to use for security and querying?



You don’t specify the link to the database in the Project Settings:Targets, but it is a requirement to have that set up to your webserver (local or otherwise), before you can set up the Database Connection in Server Actions. I set up my Target to a local WAMP server, which required me to also download and install the Microsoft Drivers for PHP for SQL Server (This was a bit of challenge to get working, but let me know if you have any questions if you go this route and need assistance). Once your target is set you can click the Test Connection button and if you receive the Connection Successful dialogue then you can move on to creating the Server Action and Database Connection. You can then follow the normal instructions to create the database connection. When you set up your database connection you will be able to choose either SQL Server or SQL Server native, whichever works best for you. The biggest challenge for me was to get all the setup steps correct, but once they are Wappler has no problem with connecting. I have set up a dozen sites and apps that take advantage of SQL Servers and the system has been bullet proof.


Brian C. Martinez

Hi Brian,

I am unable to connect to any MySQL server - I tried both local and on AWS. They’re working properly and connectable, however every attempt to test the database connection results in an error:

Which I think suggest that Wappler is actually trying to establish a connection to the Web server instead (which was defined properly btw in the Project settings)

Would appreciate any insight you might have on this.


Wappler tries to connect to the database server details you entered in the database connection dialog.
It pushes a connection file to the selected Target in the targets menu (bottom) and connects from there.

Are you sure you’ve properly set up your target and what is entered there?

1 Like

Thank you for the prompt response, Teodor. Much appreciated

I believe I have set the target correctly as the webserver test connection works fine:

What is your server type? And have you selected the target at the bottom of Wappler window?

Yes, it is trying to establish a web connection.

Wappler does not interact with the database directly, it uploads a connection script to your webserver and interacts via that.

The issue you are experience is normally related to an FTP setting issue.

I know you can connect via FTP but are you connecting to the correct place?

In most cases the FTP root is one level above the web root so the ftp connection needs to be pointed at the correct directory, often public_html, htdocs or www

Ensure your FTP points to it correctly

If the remote directory setting in your FTP connection settings is blank that pretty much confirms that.

1 Like

Yes, I have selected the Target at the bottom of the Wappler screen.

The webserver is actually a free hosting service at

I’m not sure about its type, however it supports PHP.

@Hyberbytes - Indeed the Remote Directory is set to /htdocs, as required by the hosting service

I can’t see the error message properly but it seems to infer that there is an issue running JavaScript. As i don’t know how Wappler manages this I can be sure but check JavaScript is enabled in your browser in case it is related.


Also i don’t see a username input in the background image, are the full settings entered?

Take a look at their knowledgebase which will probably clarify then issues

Certainly the server address should not be localhost


Make sure you are using the right database hostname (not localhost)

Most hosting providers use localhost for the database hostname. This does not work for InfinityFree. The database hostname should look like sql123.epizy.com . You can find your database hostname in your control panel in the MySQL Databases section.

Full instructions are here

1 Like

Thanks a lot, Brian.

I also just found the following post:

So I guess the mistery is solved :slight_smile:

Anyway, I was able to establish a connection MySQL server hosted on AWS, when setting the project target to a local XAMPP webserver I installed.

That last one is not actually relevant. That is why wappler uploads a connection script and communicates with the database via the web host. That way connections are not external, they are local.

My preferred host has strict rules for external connection I have to adhere to when using software like navicat but Wappler connects without problem as it does connect through PHP scripts uploaded to your free hosting account as specified in that post.

1 Like

Good point.

However, I’ve verified the settings for connecting to the InfinityFree MySQL database (I previously only tried to connect to a local and AWS MySQL servers, which I realized is not allowed) and I’m still receiving the error - so I suspect they have some kind of a restriction on this type of connections

Actually, taking another look at the post I just (finally) realized that there shouldn’t be such a restriction, as you noticed. So I’m going to check that out with their support.

Thank you very much for your help, Brian!

I have registered a free account, will take a look myself and see what needs to be done. May be tomorrow morning though

Thanks, Brian - however I think I’ve found the reason why this doesn’t work:

Specifically, check out the link in the second message

That explains the javascript message I referred to earlier. Free it may be , useless it obviously is! Javascript is part of the HTML5 standard,
Crazy to block it,