JSON not found when using at data view

OS info

  • Operating System : Mac OSX 21.4.0
  • Wappler Version : 4.7.3

Problem description

Error message when using JSON data for data view.

Steps to reproduce

  1. Add JSON Data Source to the APP
  2. Add data view to the APP
  3. Choose a data source

Try putting the json file in the public folder. Views is not accessible client-side

Hi @bpj,

Move it to the public folder. However, remains the same.
Any step I need to do after modifying the folder/doc from the file manager menu?

Found the error, try to locate the JSON data location correctly.
Seems like the issue was coming from ‘File Selector’ button. When choosing the file using this button, the url become ‘/data/meta2.json’.

I tried to remove the ‘/’ in front, now it works.

1 Like

Wappler Version : 4.9.1
Operating System : MacOS Monterey - M1
Server Model: NodeJS
Database Type: Postgres
Hosting Type: Own Server

Looks like this issue is still present, so I’m unable to use the JSON Data Source component. Removing the ‘/’ in front didn’t resolve it for me unfortunately.

1 Like

did you locate the json data inside a public folder?

Hey Cheeseguy

im having the same issue, have you found the issue/fix? Ive everything I can find on forum but no luck

Fixed in Wappler 5.0.4

This topic was automatically closed after 32 hours. New replies are no longer allowed.