Issues with paths on remote server

I took a look at dmxAppConnect.js and I noticed that the code stop color coding that "f(). My guess is there’s a typo or something messing. Here’s a copy of the code. Strangely enough, the local Connection which connect to the remote server, works. Just when I publish the files to my remote server, neither CSS nor the connection string work


Your database connection has nothing to do with the App Connect js code.
You can debug the server side errors as explained here:

Have all of that set up. The problem is it’s a form with two select drop down controls that populate when I view it from local host but not when deployed to the remote server pointing to the same remote database. I’m evaluating Wappler but have spent about 20 hours trying to get to simple apps deployed to my remote server. I know exactly how great wappler is as a form intranet developer. Because I’m new, I can’t tell what’s an error on my part and what could be a bug. works locally and actually has a Light blue background not this white background but if I change the tittle to Manufacturers - Version 3, it will change on my server when I publish it. There’s got to be something very wrong with the file structure relative to the main document because everything seems to be in the right place but it’s not working. It’s got to be a simple fix or maybe I need to total delete if from my desktop and reinstall it but I rather not recreate it. If I can get this one simple form working, I’m keeping the monthly subscription because I know what I can create with this. I deployed a desktop application written in foxpro to work on Pfizer’s company intranet. I would have loved something like this!!! Please help! It’s got to be the connections string because I can type the string in manually and it works. Thanks.

Works great from my local Apache instance. It’s reading a remote database or at least it’s supposed to be. Then I publish the files to my remote server and I get this.


Nothing in the dropdown. But nothing is different. I can see in Wappler that the filter is triggering correctly. But once it gets to my remote server, the selects aren’t populating.

I think the last issue on this page is your database connection.
It all looks really messed up on that link your provided, files are missing/not found so that it looks broken. Your files are in some subfolder handbags/www/ and most probably this breaks the whole thing, if your local setup i using different folder structure.

Also it seems on your remote server the detailed errors are not enabled so it doesn’t report the missing files / wrong paths (i.e. the 404 errors) so we can’t see where your page is trying to locate your files.
For example, this file is not on the following location: but your site doesn’t report it as missing.

Contact your hosting provider and ask them to enable detailed errors.

Hahaha. I am the system admin. The site is in handbags/www because there’s a wordpress installation in handbag/ I wanted the form to read the handbags database and return a unique list of manufacturers. In addition to copying the files over using the the ftp feature in publishing, I’ve tried to ftp them over using Filezilla with the folder intact. If t works fine on the local Apache instance and I copy everything over to the server, it should work. One thing I haven’t tried is to replace the MySQL server ip address with “localhost”. I didn’t think that would matter but it’s worth a try. I’ve deleted everything from the server a few times and I delete Wappler at least once. AppConnect.js is in

This is how it looks on the server. Coming from one server to another, it should be permission right I don’t think. I’ll check that in terminal.

The permissions look ok.

Again, there is nothing realted to any permissions.

There is no need to delete Wappler or reinstall it etc. Wappler installation is not related to something that is simply paths issue.
If you are the server admin then please enable detailed error reporting on the server so that you can easily debug errors like missing files, now these errors are not being reported by your server!

Your page has links setup to site root relative, you can see this when looking at the source code of the link you posted:

<script src="/dmxAppConnect/dmxAppConnect.js"></script>

so the page assumes this file (and the rest of the includes) are located in the server root.
For your page, being located in a SUBFOLDER in your server root:

the link as above points to the site root:

and not to its actual location

That is because locally your site root is not in a subfolder!
That is the whole issue - paths and folder structure.

Change the paths from Site Root Relative to Document Relative in the project settings and re-save your page, so the links can be saved as page relative. Then upload your page to the same location once again. This should fix the issue you are having.
And remember that you can’t just randomly upload your files to some subfolder of your choice, not taking the paths in consideration.

Here’s what I did. I deleted everything then created a simple form with a select of manufacturers. It would work locally but not remotely again. I deployed it remotely using relative to the relative to Document option. It didn’t work. I then removed from the index.php file and added a period to and the connection string worked. Of course all of my hard work may be gone for the other project but I’ll recreate that tomorrow. But the CSS is now working so maybe I can recreate the project correctly. Here’s how it’s supposed to work but it’s missing the data. There’s something I may not be doing right when publishing it to my remote server. I know the difference between Site Root and Document but I’ve been at this for quite a while. First issue is in order to bind to my remote server, you have to change the MySQL binding to bind = bind defaullts to localhost

This is still a path issue, your App Connect include points to a wrong location still:

<script src="/www/dmxAppConnect/dmxAppConnect.js"></script>

this should be

<script src="dmxAppConnect/dmxAppConnect.js"></script>

if you want to make it work in this subfolder …

And btw your server still doesn’t have the detailed error reporting enabled and doesn’t output 404 (or any other) errors, which makes it really hard to debug issues there.

Thanks a lot for your help. I saw what you were seeing and manually corrected the problem by removing the and putting a “…/” in front of the connection string call. There must have been something I’m doing after I create the project that is scattering some of the folders because I can see the folders being copied into different locations like some are going to the root folder and others are going to WWW. This is messing up the relative paths. is how I left it. Every time I change the project and publish it I have to perform the steps above. But then if I try to change the paths of the project, the system tells me I can’t. I’ll try to create another project and pay attention to the ftp remote folder in addition to the folder for the other assets. My guess is the remote folder might be throwing things off. Thanks again. I love this program!!!