Install Stripe CLI Locally bug

Continuing the discussion from Getting Started with Stripe Webhooks:

The above step does not seem to work in Wappler v.6.5.1. MacOS, Apple silicon.

Repro steps, in target development.

  1. Set up stripe webhook (as per documentation)
  2. Select Stripe Webhook in terminal dropdown. (as per documentation)

What happens.

Prompt opens requesting you to add Stripe secret Key.

What should happen (according to documentation)
Wappler should install Stripe CLI locally.

Not really, according to the documentation the Stripe CLI will be installed when you select to start Stripe Webhooks terminal:

Hi @George

Yes, I think that's what I'm saying here?

When I open the dropdown AND click on the "Stripe webhooks" option. It does not initialise a CLI install, and the terminal does not display

copy file dmxstripe.js
copy file stripe.php.

instead the confirmation dialogue asking if I would like to enter a stripe secret key opens. And the way I understand the documentation, that is not the expected behaviour, instead the CLI install should kick off?

I just tested the whole procedure and the Stripe CLI was installed as per documentation.

You had to have a valid Stripe API key entered and also create a webhook under the server connect webhooks before the Stripe CLI can be installed.

If you still have problems, please enter your specific OS info and version and also produce a debug log.

1 Like

Hi @George

Thank you so much for looking into this. You're of course correct, adding an API key under SC settings does the trick. No bug here, but perhaps a small update to the documentation highlighting that the API key needs to be added before testing a webhook might be a good idea?

I might have missed it, I re-read it but couldn't see any mention of it.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.