Image Upload Not Providing Path or URL... Under Certain Circumstances!

I’ve been following the latest tutorial videos from the wonderful @Hyperbytes that deal with image uploads and processing.

Using a Wappler Local Server/NodeJS setup, I found that although the image uploaded and appeared in the correct folder on my computer, the part of the tutorial where the path was written to the database wasn’t working. And, interestingly (or not), the ‘url’ field in the output was blank.

So the Image Upload would produce output like this:

    "upload": {
        "name": "example.png",
        "path": "public/userdata/2/example.png",
        "url": "",
        "type": "image/png",
        "size": 40285
    "insert": {
        "affected": 1,
        "identity": 36

And although the other information would update the database, for example the identifier of the user who uploaded the photo, the column for image path remained blank.

I tried lots of trial and error, creating different Set Values with output and setting them to various different parts of the API to try and get some information (eg upload.path,, etc etc), basically using my own ignorance to cast a wide net to try and get somewhere. None of these produced anything in the console, despite output being selected.

A little later with no luck I pushed my changes to git and went about my day. Later, on a different computer, I decided to clone the project and have another go… and this time it worked as it should. No changes were made, it just worked.

Not wanting to rock the boat, I tidied up the mess I had previously made with all the extra Set Values and pushed it back.

Now back at the original computer I have pulled the ‘working’ version and the original behavior has returned and it is not working.

So my question is: what could be wrong/funny/different about Computer A which is stopping this process from working properly? Anything I can do to diagnose and change?

Thanks in advance. And please consider in your response that you’re talking to someone who followed an excellent step by step tutorial and still didn’t get it working! :grin:

Try deleting the API Action (thus deleting the JSON file), and start over.

Thanks for the reply @ben. I’ve just tried that, unfortunately it hasn’t helped.

Here’s another fun detail (I’m using the word ‘fun’ here liberally).

I tried to add a search box to my table to filter the results for a table, also based on a @Hyperbytes tutorial, and that didn’t work in the Wappler Local Server environment. And this is something I’ve done before with success.

So this is a completely different API, doing something completely different… and it isn’t working. But if I switch to production and build and deploy the project as a docker container it works fine. Likewise, if I push my project to Git and pull it from a different computer, it works fine.

Any ideas what could be causing this behaviour? Computer A (the one not working) is a Windows 11 laptop, Computer B (the one where it works) is a Windows 10 desktop.

I use both win 10 and win 11 without issues.
As the problem is localised to a specific machine I would suggest the issue is one if setup.
Perhaps a clean reinstall of wappler on the problem machine?

Thanks for weighing in Brian, I’ll give that a go.

Have you run a System Check on the affected system?

Hi nomad, thanks for the response. Yes, System Check comes back fine. I’ve also reinstalled Wappler on the affected machine and the problem persists. I still hope there’s some obvious mistake I’ve made. I have projects on the affected computer that perform similar actions fine - like the original tutorial I followed.

Unfortunately my next step is to start a new project and seeing if I can get different results… I appreciate everyone’s responses.