How to publish to NPM

I keep getting this error when I try to publish a widget.


Please could someone (@JonL ?) help me out? The source code is within the ZIP file. (4.9 KB)

Have you tried whoami, logout/login,
The path is right as i see ./ ? (i mean why not just npm publish – access=public)
The package is on read/write option instead of read?

Thank you, Francisco, for your reply.

I tried the options that you mention, without luck.

If you want to try the Component yourself, copy the contents of the ZIP file to the site’s root directory so that it looks like

To install the Component locally, open Project Setting -> Extensions -> New Extension:

Follow the instructions in the file.

I hope you like it.

1 Like

Hi Ben,

You need to register your @ben name first (if someone else haven’t got it yet…otherwise create a new unique one first, make sure you adjust the package name afterwards ) and then login with it.


1 Like

Thank you, George, will try that later on tonight. Sounds logical once one knows.

Thank you @George, with a bit of fiddling around, I realised that I had to use @username for the scope.

In my case this became @benpley instead of just @ben.

To install the extension, enter @benpley/wappler-theme-changer in Project Settings -> Extensions.