How to make a POST using multipart/form-data?

I’ve tried several ways to make the request, but the api I’m using to POST always returns the following error: no files received.

That is, the files are not being sent by the form with enctype multipart/form-data. I tried via insomnia and it is sending normally, I would like you to help me with this



Are you setting enctype?

form action="" method=“post” enctype=“multipart/form-data”

Yea,. I already configured it, do I need to configure something else?

<form enctype="multipart/form-data" method="post" action="/dmxConnect/api/integracao_asaas/contas_bancarias/enviar_documentos.php"

I’m using the connect app on the form, do you have a problem with the connect app for this case?

can you screenshot your form action on your page so we can see how it is configured

I’m using a bank api that I’m using to open accounts through the back end. how to act in this case?

I can’t use it directly because I need to pass a token in the request header

By insomnia I can’t make the request, but neither by wappler nor by postman I can make this request

1 Like

no news about it ? ( novidades ?)

I tried this last night as well and have the same issue. The file shows up on the Inspect Element Network tab but it never actually gets sent to the API.
Our API is returning an error informing me that an empty file has been passed.

Try taking the link to the file not from POST, but from ‘upload’ in the File Upload step