How should I set formatDate?

If you can not do a toNumber() can you do a

<div class="d-block" dmx-text="[0].eventstart.toDate().formatDate2('d')"></div>


<div class="d-block" dmx-text="[0].eventstart.toTimestamp().formatDate2('d')"></div>

to change the string first Teo?

Just asking for my own learning too.

Edit: Nevermind I saw your answer, without App Connect then nothing will work.

Thank you. I got a same error for both lines.

As Teo said if you have no App Connect it will not work, make sure you have that first, and then there will be no need for my workarounds too.

Please check my reply above!

You can’t use app connect components if it is not included on the page.

@Teodor you mean this one?

Yes of course! That’s the most important part of Wappler.

The app connect js file is missing from your page head tags.

but it seems already set…how can I amend it?

Well if you created the page in Wappler and included it on the page, its js include will be on the page.
Looking at your code you probably copy pasted some parts of some page in another empty page, so app connect didn’t get included on the page.

Use the menu on your screenshot to add it please, and don’t copy-paste code around the pages if you are not sure what you are doing, please.

ok got it…I try to do this from a new page (not copy and paste) again. thanks a lot!!

@Teodor after getting your reply, I made a new file, then it worked on Wappler!!!

but when I use the browser…

I could not get the data…

And these are errors…

what should I do next?

Have you tried clearing the browser cache?
Please make sure all the files are uploaded to the server.

yes, I made sure with them.
then I still get this.

I’m sorry but it is really hard to tell what’s wrong on your page without seeing it.

I see your jquery include is probably missing on the page now.

Please upload your page to some server where i can access it and check it. We are just going in a circle right now, wasting both ours and your time guessing what you might have done wrongly.

Somehow I deployed the copy to DigitalOcean.

could you please have a look at ?

I’m sorry but this ip loads nothing:

sorry, I fixed it.
I think you can access there now.

Nope, it’s still not accessible

how about copying IP number part and paste it in the browser directly?

It doesn’t make any difference.

Please can you just upload your page to some server where it is publicly accessible… we started with a date formatting issue and now we are debugging your server connectivity.

A problem that could be fixed in like 10 seconds by me looking at it already takes more than 3 days!

Sorry for taking your time.

I uploaded it on the production site,

but got an error below.
“SQLSTATE[HY000] [2002] php_network_getaddresses: getaddrinfo failed: Name or service not known”