How do I set up SQLite with nodejs

Morning good folks :slight_smile:
I have a slight newbie hickup :slight_smile:
I am trying to set up a new project with nodejs and SQLite on my local machine but am guessing I am getting the steps in the wrong order. Everything is fine, the nodejs server is running until I add SQLite. First I get an error message saying SQLite is not installed and then a spinner with a box pops up telling me:
Query database schedule. I have waited for a while but nothing other than this box is on my dashboard and otherwise the wappler dashboard is inactive
Might someone know how to set this bad boy up?

thanks in advance

HI Linda,

Could you share some of the error messages? It will help us narrow down the problem you have.

Were you able to just add SQLite in the Database Manager as connection and then edit its data?

Hey there George…this pc of mine is ancient, so print screen isn’t even possible anymore, so unfortunately cannot send a screenshot. What happens is that I set up a blank web project, then I add my server handler nodejs which works just fine and wappler asks me to install all necessary dependencies and then I go to the database manager and choose sqlite and that’s when wappler stalls…it gives me a glimpse of a message saying "you haven’t installed sqlite and then goes straight to showing me a box with a spinner saying:
Query database schedule.
this message freezes the wappler dashboard…I’ll see if I can install sqlite first, maybe that’s it :slight_smile:

You can just install a screenshot tool like: and attach the image here.

Hey there @Teodor and @George :slight_smile:
finally figured out what the problem is. I haven’t installed sqlite 3 correctly. I ran a test on the database connection which gave me: error connecting Knex: $ npm install sqlite3 --save. So fired up the powershell terminal and cd into my project and ran the npm command: npm install sqlite3 --save. also tried from my root user and it seems to install correctly, but nonetheless I keep getting the same error message. I also tried to use the wappler terminal but I don’t quite know how to run npm in it? tried typing in the command but nothing happened