How do I find the server Address in connection of MySql Dataqbase

Hi every one,
I have hosted with Blue host and in the cPanel, I created a new database
but when I come to wappler, It somewhere asks for the server address.
How and where do I get the server address while using the control panel from blue host.
kindly help

The address of your database server is usually available in your hosting panel.
You can also contact your hosting provider.

they have given me the ip address but its not working

“It’s not working” is never a good explanation of the issues you are having.
Please provide detailed step by step description and screenshots explaining what issues you are having.

step one

then I tried to make the connection


ERROR Message

I dont know how to fix that please

I am using Blue hosting

What target have you defined for your project?
What server model are you using?

PHP model

Can you please answer all my questions?

sure lemme check

so is that the Wappler local PHP server?
Can you confirm it’s running?

Also, are you able to define a connection in the Database Manager?

When I try to test connection , It fails
even when I change the option from wappler server to own server the connection doesnt happen

it shows this

Well check the bottom panel to see if the server is running.

You can’t change it to “own server” just like that if you don’t have an own server running…

But are you using the Wappler local server or your own server? Your screenshots show “Own Server” is there actually a local server running on localhost on that port? Something is really messed up in your project/target settings.

Maybe just start from scratch and if you want to use Wappler’s local server to run PHP, create a new project and follow the docs:

here are the current settings please

the images before I was doing trial and error to see oif things work

okay lemme try that

Thanks so much Teodor

Your such a blessing…!

But that’s totally messed up! You can’t put your database server address in the local web server address field.
Please recreate your project and try again. Also - don’t change the local dev target settings.