Having trouble testing FTP connection


I am new here! Sorry, if this is a dumb question. I have been struggling to get the FTP test connection to work. I have been using Namecheap to host the website. When I created the FTP account, I set it up in the /home/nenuytil/teja path (FYI: the server directory seems to be home/nenuytil).

On wappler, I get the error “Can not find the uploaded files!” for the following settings:
Web Server url: http://nenu.co/
FTP Server: ftp.nenu.co
Remote Directory:

From the guide, I know it is either the url on the remote directory that is wrong but I am having trouble figuring out what the right one is. I get the same error adding “/teja” or the full path at the end of the url. When i add any permutation of the folder names to the remote directory, I get a “can’t change directory to …” error.

How can I resolve this issue? I spent more than 4 hours on this problem. Please help.

hmmm… at namecheap it looks they use cpanel:

Maybe it is :


if not try


sadly there is no standard for setting ftp default path

Thanks Freddy. Will try that out and let you know.

Folks, I have finally managed to resolve the issue! Documenting it here for the future.

Turns out I screwed up while creating the FTP account in the first place. I should have created the FTP account within the public_html folder. Instead, I created it in a different folder which is why it had trouble connecting. I created a fresh FTP account within the public_html folder and left the “remote directory” blank in Wapple and voila. Connected instantly!

1 Like

Yes, in most cases service providers standard FTP path setting points on directory above the web root so you either need to redefine it as you did to point to the web root (in your case ‘public_html’) or set the remote directory to the web root, again your case ‘public_html’

That is without doubt the most common problem when new Wappler users set up FTP connections and if it is wrong then database connections also fail

1 Like