Group By and Count filters missing

Used Operating System

  • Mac OS X 10.12.6
  • (Wappler: 1.1.2)

Steps to reproduce

  • Try to use Group By filter


  • relevant filters and bindings unavailable

I tried to follow Using the Group By Filter demo (on, but most of the relevant options seem to be missing in Wappler. I used some code I had used in the past with DW and could get the result I needed. If I used the formatter and tried to select the variables I had entered manually (which were working correctly) - the error messages as shown below appeared.

Yes there is an issue with that and also with filtering. These are some of the most important functionalities in AppConnect and should be fixed soonest possible.

Thanks for confirming that. Hopefully these issues will be fixed this week.

Hi Tom,

You should not have this issue in the 1.2.2 version.

Hi Teodor,
It was the 1.2.2 version I was using (ie the current version).

I cannot reproduce this - everything works fine.
Can you make a short video from the beginning so we can see what’s wrong?

I was travelling somewhere, using a MacBook Pro, when I was trying this out. I usually use a Windows 10 computer (eg now) - though I don’t suppose it should make any difference. I don’t have any screen recording software on the Mac, but I’ll try to replicate this on another computer later and make a demo .

1 Like

yeap this issue but not for only filtering … If you have bad html tags or etc. you can get this issue


create span tag and choose it then click attribute ( you will see twice attribute panel ) then create simple action … you will get this error .

I think this is confirmed bug … ( Im not sure )

I can confirm that I have run into this too. Generally in code view and generally when you add your own span tag in code then try to interact with it.

So can you guys tell me how are you using the group by and count filters so that they display this error?
I just tested with a dynamic table, dynamic bs4 row - couldn’t recreate the issue.

hello @Teodor,

please create span tag inside Count field then bind it

To bind what to the span tag?

forexample ;
<td><span class="badge badge-warning"> {{abx.count()}} </span></td>

you will see 2 error

1 is duplicate attributes right bottom of wappler
2 is unknown variables error

Please explain STEP by STEP what exactly are you clicking as i just did the following and it works perfectly:

  1. Add span
  2. Go to DOM panel and select the span
  3. Add Dynamic attribute > display > inner text
  4. Bind the $value.count() filter

1 Like

yeap there is no issue if we use DOM Panel… ( for duplicate attributes…)
I didnt tested for unknow variables …

Well App Connect panel does not show the common HTML tags, it shows only the components - app connect components, bootstrap 4 components.
How do you even select span tag in App Connect?

For working with common HTML elements use the DOM tree, that is why it is included in Wappler.

I'm using code view and manualy select ..

maybe you can hide the elements that are not added to the wappler. It creates confusion.

…and I will sent you screen shot for unknown variable issue … But I have to reproduce this error…