FTP on Windows fails

OS info

  • Operating System : Windows 10.0.17134
  • Wappler Version : 1.2.5

Problem description

upload error when creating database connection to SQL server2012

Steps to reproduce

when laking a new database connection and new query I get an upload error that files from dmxConnectLib are not uploaded. I fixed it by manually uploading the folder.

I keep getting similar upload errors al the time, errorcode 504
Is there a way to copy the content of the warning box, or enlarge it that it is more readable?
It gives a long repport and is quite unreadable in the small box.

ad to this, similar error when creating new database action, I get 550 The specified path is invalid -> MDTM rules, also for MDTM auth, core. also errors 550 cannot create a file when that file already exists.
Also 500 ‘SITE’: command not understood (./lib), chmod; Access failed: 50’SITE’ command not understood,
chmod: operation not supported: MFF and SITE CHMOD are not supported by this site.

note: trying to publish that to a windows 2016 server with MSSQL2012 db.

Hi Bart,

When publishing to windows ftp you have to turn off the chmod option in the target options:


Because this is not needed on Windows.

Thanks, I changed it.

But I tried to make a very simple insert record page and got this error:
‘A server error occured, to see the error enable the DEBUG flag.’
Where can I enable that please?

Just enable it in the server connect options: