FTP error connection without VPN

i have this issue since i started using wappler but dont know where is the issue.

the issue go away when i use a VPN and i can connect successfully . how can i fix this? where should i look at?

Turn on Debug, the bug icon on the bottom toolbar. It should then show more information in the terminal.

I had a similar issue just last week. I got in touch with the host who told me that my real IP address had been blacklisted by the host. Cause unknown. A reset by the host solved the problem.

Not sure if this is the case for you, just thought I would put in my two bob.

Start upload for stocks_list.php
+ set color:use-color yes
+ set cmd:interactive yes
+ set file:charset utf-8
+ set xfer:clobber on
+ set ftp:timezone
+ set cmd:show-status yes
+ set cmd:set-term-status yes
+ set ftp:list-options -a
+ set cmd:fail-exit yes
+ set cmd:time-style "%b %e  %Y|%b %e %H:%M"
+ set ftp:ssl-allow no
+ set ssl:verify-certificate no
+ set net:max-retries 1
+ set net:timeout 10
+ set net:reconnect-interval-base 5
+ set net:reconnect-interval-multiplier 1
+ open -u ---------
---- Resolving host address...
---- 1 address found: -----
+ cd Beta
---- Connecting to ftp.shaqra-email.com (-----) port 21
<--- 220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
<--- 220-You are user number 2 of 50 allowed.
<--- 220-Local time is now 06:50. Server port: 21.
<--- 220-This is a private system - No anonymous login
<--- 220-IPv6 connections are also welcome on this server.
<--- 220 You will be disconnected after 15 minutes of inactivity.
---> FEAT
**** Timeout - reconnecting
---- Closing control socket
cd: Fatal error: max-retries exceeded

but i have reset my modem. that changed the ip and still not working

In the welcome message it says TLS, did you setup the ftp access type as FTPS?

Not sure why it would work with a VPN connection, can it be that the IP from the VPN is trusted for unsecure connections.

its setup as FTP.
i can connect with my ip from other program with no issues or VPN

The only thing I can see is that it got a timeout on the FEAT request, normally the server should give back a 211 response with the features it supports. It did connect to the server, perhaps you can get more information in the log from the ftp server.