Framework7 v2 elements


#1

i tried to great a simple page with a form in it and it took me 1 hour and still the form is missed up
for example:

when i add the form to a row then change the handler to DMX then refresh the page the form shows in the app structure as the child of the App node (root) but still show in the correct place in the code view (child of a row)

the bottom bar does not show at the bottom on wappler but after i upload the file it shows correctly on my phone after browsing to the page.

adding more than one page (or popup) will cause issues in the design view (only the last page is viewable)

i found these issues just buy trying basic stuff.

wish you guys started with fixing the framework instead of cordova stuff

hoping for more stable release this week :slightly_smiling_face:


#2

Yes in this week update we will fix also all Framework7 v2 form elements. Those were left as in v1 but seems the structure changed in v2 also drastically


#3

Tested v1.1.1

-toolbar is not displaying correctly.
-multiple pages display on design view is still not fixed
-browser is complaining about a missing js map file (i add it manually)

can add form elements but wappler add them out of the ul(even when i select them to be added after the list element) so i must go to code view and get them inside the ui element to display in the app view correctly

pretty disappointed actually :neutral_face:


#4

As for the form items - those are inserted under list elements. You actually start with “field input” and in its inspector you can change the type if you wish:

will check the other issues


#5

Btw it will be really helpful if you are testing things and for example toolbar or something else you think it doesn’t work, see how it should be in the official Framework7 docs:

http://framework7.io/docs/

and see what we are generating, so just post directly the difference between what you got generated in Wappler and what it should be according to the Framework7 docs.

This way we can directly fix it and not doing a huge research first of what do you mean exactly …


#6

I take the code form their site and paste it
That how i can know that its not working from the start.

The thing is that these issues are pretty basic
Anyone from the team do any teasting?
Right know if you try to make a CRUD with the framework you will not be able to. So i guess you guys test simple elements and randomly.

I will post images for the issues to help solve this asap.