Framework 7 v2 and v4 showing - routes not created

Trying to start a project with electron and Framework7 aurora desktop theme.

When I add a route it seems wappler cannot find the routes.js file at first. It is not created automatically. I then created one and pointed the settings route option to the newly created routes.js page.

Nothings gets written to routes if I try and use it the same way as I use it when building a SPA for apache.

There is also another framework7 version 2 folder created:


Think these are bugs… has anybody managed to get Framwork7 routes to work with Wappler? I did it manually a couple months ago, but would like to build everything with Wappler.

I get this when I add a routes.js file using the settings interface of Wappler:


I see I had similar problem in past - going to go to those posts and see if I can fix this manually.

Would be great if there is a Wappler way of doing this.

1 Like

it seems only you and me are interested in framework7 :sweat_smile:

It is easier to work from Framework7 docs and manually code the things… Think FW7 Wappler integration has to be polished some more. Believe the devs will get around to it. They are adding great stuff every week.

1 Like

that is exactly what im doing. using wappler as a code editor mostly on framework7.
and relying on framework7 docs

1 Like

What does work is the following workaround:

  • Add new mobile project
  • Select Kitchen Sink FW7
  • Add Electron as a platform
  • go to settings and select routing and the routing points correctly automatically
  • go to app.js and change var theme = ‘auto’; to var theme = ‘aurora’;

Routes should work fine with Framework7 v4.
Are you sure you are using the latest one?

And also that your project is a mobile project and not a web project?

I have started it as a mobile project and not aa desktop project. It does not work straightforward if you start as desktop app and then add Framework7. Maybe you can just look at that.

But if I do as in my previous post and use kitchen sink as starting point, I am able to get going pretty easily.

Have you enabled Routing in our project options and does the Routing File points to the right file?