Form Select causing 500 error

I’m having an issue with an insert form. If I submit the form using text fields and just input a number for id fields it adds fine. If I make those selects with the value being the id from the referenced table I get this error -

serverconnectForm.js:249 POST 500 (Internal Server Error)

_submit @ serverconnectForm.js:249
submit @ form.js:41
onsubmit @ form.js:71

Hi Heather,

We can’t see much from the link you provided…maybe you can add some screenshots of your server and app connect actions.


Maybe the message that I see will help find the problem
A server error occured, to see the error enable the DEBUG flag.

Note for @Teodor: occured should be occurred


Please check the following article, explaining how to enable the debug mode in server connect, so we can see the exact error:

1 Like

Hello, I have got a completely same error.

And I attach the error message here.

This error says, ‘iduser’ is missing.

But I set like this.

Like this insert, I would like to input {{security1.identity}} as a value of ‘iduser’.
But error occurs, which means this is not inserted…

Please let me know how to solve this problem.


To use this value (and actually be able to select it in the data picker) you need to include the security provider step in your server action, before the insert step!

1 Like

I already set it too though, do I need to set security provider separately? Or should I include it in the same place as insert setting?

I believe you need to add it to your server connect action. You are missing it in your screenshot.



Oh, I added on this part right now!!
and it worked! thank you so much!!


Excellent, glad it’s working for you. Welcome to Wappler!


You guys are always helpful!! I really appreciate it!!

1 Like