FileNotFoundError during traefik install

I’m trying to enable HTTPS for my project on staging hosted on AWS ec2 plateform.

Wappler Version : 3.6.1
Operating System :

  • Windows Pro
  • Version: 1909
  • Version OS: 18363.1256

Server Model: NodeJS
Database Type: Postgres
Hosting Type: Docker
Docker Engine: v20.10.0 (WSL 2 based engine)

Expected behavior

What do you think should happen?

Install Traefik.

Actual behavior

What actually happens?

I follow the path:

  • Project Settings
  • Targets
  • My Target Staging
  • Manage Docker Remote
  • My AWS Machine

When I click the button ‘Apply’ after toggle on ‘Install Traefik’ and put and email address, nothing happen, but when I ‘show logs’ an error is shown:

ERROR: .FileNotFoundError: [Errno 2] No such file or directory: '.\\docker-compose.yml'
1 Like

I also get the same - this is the only relevant post based on the error. Did you come up with any reason and or solution?

1 Like

My solution was to add traefik manually in docker-compose

That shouldn’t really be necessary. It is all generated automatically.

What were the chosen settings and where is your user folder located?

Do you have a docker machine folder in there?

1 Like

I tried all settings (with and without dashboard) (I’ve tried it on december and I’ve retry in January) inside the settings of docker machine (AWS) (just traefik not portainer).

For my windows user folder is the default location (french OS so some folder have different name than a en-us OS):

If you go inside those folders you should see a sub folder Wappler with docker-compose.yml inside ( for the docker machine that you selected to install traefik)

Do you have this?

1 Like

I don’t find it in both machine folders:


Exact same issue here.

No .yml file found when trying to build docker with Traefik.

Any manual way out ?

What were the UI options you choose to install traefik?

Selected everything. It fails. And then scres up my redis so I end up having to create a new Droplet on Digital Ocean to get things moving again

Can you paste the logs when if fails?

I will if we do it again but we’re leaving it for now as it also corrupts our builds - REDIS no longer works and we’ve go to start from scratch with new dockers.

At this stage, we’re probably going down another route using a load balancer. Putting more layers into Wappler/Docker feels too risky for us as we’re close to release.

Thanks George.

Well it shouldn’t impact Redis at all. Each docker container runs on its own, no matter how many you have.

So traefik, Redis, database, web - all run in separate containers

I know it shouldn’t. But it does.

We’ve set up a Digital Ocean Load balancer with Let’s Encrypt and that route is where we’re going. Trying to minimise Wappler/Docker exposure at that side.

Thanks again Geroge.

This has been fixed in Wappler 3.9.5

1 Like

Please post different issues in different topics.
If you have a link you can’t share publicly then send me a private message with detailed explanation and an URL and I will check the issue when on my computer.

This topic was automatically closed after 28 hours. New replies are no longer allowed.