File image management, i.e. image processor, etc

I am having difficulty with editing the image after uploading and inserting file data to the database.

After trying many times unsuccessfully, I finally went back to DW and Bootstrap 3 and the process worked as it should.

Am I correct in thinking this extension’s features are not available in Wappler due to them being controlled by Bootstrap 3 and not Bootstrap 4? Or has this process been moved to the Medium Editor?

The file management and image processing are working fine in Wappler for me. Not sure what you are showing in the screenshot?

Wait, perhaps this is on a site you started with Dreamweaver and are trying to edit in Wappler? If so, then yes your issue is likely caused by using Bootstrap 3 as Wappler does not support Bootstrap 3.

Thanks, let me give it a try again.

Hello @revjrblack,
The steps in server connect are not related to what framework is used on the front-end.
Can you explain what exactly is not working for you there?

To add to Brad’s reply, I also have no issues with image processing. These are my multi-image upload steps.


Here’s the error message I’m getting using Wappler to manipulate image size and uploading to the database.

I tried again after upgrading to 1.1.0 and the image fails to be resized, cropped and uploaded. Something to do with the ‘out of range’ note in the error might be the issue. However, I have no idea what that means. Ha!

Feel free to offer any suggestions or corrections to what I’m doing that causes the error. Thanks!

“code”: 0,
“file”: “/Users/blaxmacbookpro/Desktop/Sites/blaxstud-upload-photos/dmxConnectLib/lib/image/Processor.php”,
“line”: 376,
“message”: “value is out of range.”,
“trace”: “#0 /Users/blaxmacbookpro/Desktop/Sites/blaxstud-upload-photos/dmxConnectLib/lib/image/Processor.php(111): lib\image\Processor->cx(-80, 960)\n#1 /Users/blaxmacbookpro/Desktop/Sites/blaxstud-upload-photos/dmxConnectLib/modules/image.php(140): lib\image\Processor->crop(‘center’, ‘middle’, 960, 600)\n#2 /Users/blaxmacbookpro/Desktop/Sites/blaxstud-upload-photos/dmxConnectLib/lib/App.php(159): modules\image->crop(Object(stdClass), ‘’)\n#3 /Users/blaxmacbookpro/Desktop/Sites/blaxstud-upload-photos/dmxConnectLib/lib/App.php(128): lib\App->execSteps(Object(stdClass))\n#4 /Users/blaxmacbookpro/Desktop/Sites/blaxstud-upload-photos/dmxConnectLib/lib/App.php(98): lib\App->execSteps(Array)\n#5 /Users/blaxmacbookpro/Desktop/Sites/blaxstud-upload-photos/dmxConnectLib/lib/App.php(71): lib\App->exec(Object(stdClass))\n#6 /Users/blaxmacbookpro/Desktop/Sites/blaxstud-upload-photos/dmxConnect/api/Photos/insert.php(8): lib\App->define(Object(stdClass))\n#7 {main}”

The problem is most likely caused by the crop process. As an example, if you have set the crop dimensions at 1024x760 and the dimensions of the resized image is 1024x740, you will get the error message.

Let me share my steps, the size of the image starts at 3k x 2k plus or minus (a photo taken with an iPhone).

What I do after uploading and then loading the image to be edited is to resize it to 600px for the height / auto for the width. After that, I crop it at 600px x 600px. Then I save it and have it overwrite the existing file.

Thanks Ben for your help!

I take it that the resized image is 900x600 which would keep it well within the bounds of the crop process.

As a test, could you remove the crop process and see if that works? If it does, replace the crop process and resize the image to slightly larger than the crop process, e.g. a height of 605.

I hope this helps.

1 Like

Thanks for your help!

After playing with this for sometime now. Ha! The image is being appropriately edited to the specified size. Perfectly!

Nevertheless, the data is still not being inserted to the database. Here’s the error message:

{“code”:0,“file”:"/Users/blaxmacbookpro/Desktop/Sites/blaxstud-upload-photos/dmxConnectLib/lib/core/Path.php",“line”:41,“message”:“Invalid Path! “,“trace”:”#0 /Users/blaxmacbookpro/Desktop/Sites/blaxstud-upload-photos/dmxConnectLib/modules/image.php(32): lib\core\Path::toSystemPath(NULL)\n#1 /Users/blaxmacbookpro/Desktop/Sites/blaxstud-upload-photos/dmxConnectLib/lib/App.php(159): modules\image->load(Object(stdClass), ‘load_image’)\n#2 /Users/blaxmacbookpro/Desktop/Sites/blaxstud-upload-photos/dmxConnectLib/lib/App.php(128): lib\App->execSteps(Object(stdClass))\n#3 /Users/blaxmacbookpro/Desktop/Sites/blaxstud-upload-photos/dmxConnectLib/lib/App.php(98): lib\App->execSteps(Array)\n#4 /Users/blaxmacbookpro/Desktop/Sites/blaxstud-upload-photos/dmxConnectLib/lib/App.php(71): lib\App->exec(Object(stdClass))\n#5 /Users/blaxmacbookpro/Desktop/Sites/blaxstud-upload-photos/dmxConnect/api/Photos/insert.php(8): lib\App->define(Object(stdClass))\n#6 {main}”}

Try putting a leading forward slash in the path, as in


It’s not a good idea to change the path manually. Server connect should set the path automatically.
@revjrblackcould you please send me your action file to and also if possible a link to your page, where i can test this.

1 Like