Error when starting server in node missing module

Hello! I’m having some trouble when trying to start my proyect server.

I’ve haven’t change anything since I last opened it. Wappler requiered an update of some frameworks and after updating it started crashing.

I’m getting this error:

Error: Cannot find module '../core/memoryStore'
Require stack:
- /Users/carlitos/Documents/02 Wrappler/latam-advisors/lib/setup/session.js
- /Users/carlitos/Documents/02 Wrappler/latam-advisors/lib/server.js
- /Users/carlitos/Documents/02 Wrappler/latam-advisors/index.js


I had the same issue caused by a Wappler upgrade a few release ago, and solved it by deleting the contents of the Wappler project lib folder and restarting Wappler, this will recreate the contents of the lib folder and add the missing memorystore.js file.

1 Like

I’ve already solved it. I take the advise for the next time. Thanks!

Good you got it sorted, think this is only an issue for projects created in an earlier version of Wappler

1 Like