Error uploading to remote GIT

Wappler Version :2.1.4
Operating System : WIN OS 10

Expected behavior

Files should upload to remote GIT

Actual behavior

Error message pops up

After clicking Abort, Retry, or Ignore, Wappler crashes.

How to reproduce

Click on globe icon, create a remote GIT repository, click the publish to remote icon to send files to remote repository

How did you setup the remote git?
What type was the url? Https or ssh?
Are you having github remote access token or ssh keys?

yes same issue…
How did you setup the remote git?
just created repo from github
What type was the url? Https or ssh?
Are you having github remote access token or ssh keys?

1 Like

Created one on Visual Studio Online (Azure DevOps now), just like the other we have.
Tried both types but we usually use https.

1 Like

we have identified and fixed the issue. Will push another update in a day or two, before we really hit those sunny cocktails :slight_smile:


I’ve tried to connect to a repo in my GitHub account but without success. Could really do with a simple step-by-step how-to.

Also, every time I click to push, Wappler just quits instantly.

I’m on MacOS Mojave 10.14.5.

As indicated above there was a problem with the push indeed.

You shouldn’t have any troubles cloning existing repo as new Wappler project though.

Just give the repo url in the options when creating new blank project

Thanks, George.

Where some more guidance is needed is with how to connect, too. What are the SSH keys for? How does it authenticate? I put in the repo URL and it just gave an error.

Also, it seems the only opportunity to enter a repo URL is when starting a new project. How do I connect an existing project to a remote repo?

Sorry, loads of questions but this is an excellent feature which I just can’t get past first base with.

There you go:


Thank you, George. I will go through that right now. Enjoy those cocktails.

I’ve gone through that tutorial and it’s confirmed I was actually doing everything correctly so I think it’s the bug with pushing to remote repo which is the problem. Looking forward to the fix.

1 Like

This is now solved in Wappler 2.1.5

1 Like

WOW! It’s working perfectly. Really pleased with it. Well done and enjoy the break and cocktails.


A post was split to a new topic: Remote Git Repository - password authentication