Error Launching Services! "network wappler-compose_proxy declared as external, but could not be found "

Wappler Version : Latest
Operating System : Mac Mini M1
Server Model: NodeJS
Database Type:Postgres
Hosting Type: Digital Ocean

Expected behavior

What do you think should happen?

I am trying to setup my staging environment with DO. I am attempting to do this using Wapplers Resource Manager.

I started seeing this error after setting up a database cluster. I have since destroyed that in an attempt to debug the issue.

When I go to ‘deploy’ it runs, and then I get this error:

network wappler-compose_proxy declared as external, but could not be found
Error Launching Services!

1 Like

Could you explain a bit more about your targets setup and what you have in the resource manager.

Thank you for your quick reply George.

This one might be hard to debug, unless an error file was automatically sent to you.

The steps I went through:

  1. I created the server, initially with Singapore (noting I had some errors selecting the server sizes as they were not available). This was created fine, and an initial deploy worked.
  2. I then created a DB cluster in the same region, simple Postgres DB setup. I could connect to this fine with external tools (Navicat).

I did nothing for about 1 week, I could guess a Wappler update happened between then and now.

Then attempting to deploy delivered the above error.

Since posting this -

  1. I have deleted all servers in DO, deleted the DB cluster in DO.
  2. Setup a new Server in Sydney region, this time no DB Cluster (just using the internal Docker DB).

I have deployed fine and now all is working - so i’m not really going to be able to help much more in terms of debugging as I deleted all of the servers/clusters. Hope that helps in some way.

May be off here, but out of curiosity can you expose the contents of your docker yaml file? Last time I had a similar error, it was an errant line injected in the yaml and this may help the debugging process. Usual location: {wappler root}/{project root}/.wappler/targets/{target name}/docker-compose.yml

Maybe just try to add some global servers like Traefik to your server, you probably will need them anyway.

They will create the missing proxy network.

thanks George, should I run into this again I’ll certainly do that.

Hi George, recreated this today. It’s definitely the external DB that is causing this issue. Traefik does fix it, but thought it would be worth letting you know for improvements.

@George I’m hitting this error when attempting to downgrade the node version from 18 to 16 or 14 on a remote docker instance. I also have a remote DB, but it looks like this is happening during the web server deployment.

It is not really node version dependent - it is more that you are saving the target options again and a proxy network gets generated while not needed.

This happens when you don’t use traefik and maybe have external cloud database. What do you use?

You can solve this by directly editing the docker-compose file for the target or using traefik that you probably need anyway.

We hope to solve this soon as well but it will be in Wappler 6

So I just remove the Proxy lines?


Ok, I had to remove all network sections.

1 Like


Fixed in Wappler 6 beta 10

This topic was automatically closed after 47 hours. New replies are no longer allowed.