Error connecting to MS SQL Server

Hi, after updating Wappler to the new version, I have a problem with Database Connections (the connection was already created previously):
When I open “Database Connection” in Globals, the test is OK

But I have the same connection in Database Manager, and the test fails!

Why does this happen?

I confirm that on the notebook, where I have Wappler 4.0.5, the same project opens the DB Connections correctly

I haven’t tested this on my Wappler, but the error says its trying to connect on port 21.
Is that correct? Maybe in newer versions default port for MSSQL must have changed.

I don’t know, but surely on 4.0.5 the test on port 21 is ok.
It is quite urgent to solve this problem for me
Thank you

The usual port for MS SQL Server is 1433
so try that instead of 21

test fails also with this port

Try just the IP address - without the \MSSQLSERVER2019

(also tried with 1433)

Well maybe your sql server is running behind firewall? Check the server configuration, on which port it is and that the windows firewall has a rule to open that port.

George, please note that no changes were made on the server, and before updating Wappler to the latest version everything worked.
In fact on another notebook (in the same office LAN and same connection), where I still have 4.0.5… I have no problem!

As we switched to newer MS SQL driver in Wappler called Tedious, seems named SQL Server addresses are no longer supported.

You can convert them to normal addresses as suggested at:

Thank you. Seems work using in “Host” and 1433 in “port” (for “Direct Database Connection”)
In “Globals” instead I use\MSSQLSERVER2019 (for “Server Address”) as I did before

1 Like

I verified my sql server is not a named instance, it is a default installation.