Error 550 lib/auth permission denied

wappler 3.0.2

I am trying to setup a new website, I have full ftp access but keep getting and error with

error 550 lib/auth
or error 550 lib/auth

I get this all the from with wappler, setting up a new site on a remote server never easy!!

It would be great if I could give wappler ftp access and it uploaded the files correctly and worked seamlessly.

Previously the way around this was to upload all the local files to the remote server but when I do that it doesn’t seem to be working either.

Does anyone have any tips?

It seems you have insufficient account priviliges on the remote server. Please check the write permissions for your ftp account.

full write permissions on everything

Is there documentation on starting from scratch on a remote server?
Do I need to create the following folders for it to work?


and add that ftp…htm file in /public

in my experience all of this needs to happen as wappler doesnt send the files or directories to the remote environment at first. Please tell me if there is a simple way.

What is your server type selected for your project? If you are using NodeJS, please follow:


Please check:

ok thanks, I think I’ll delete and start again

this is after following exactly the steps for nodeJS setup
– however it still worked.

You might want to check:

And specially the need to create .npmrc file to fix the error above