Emulator Error Windows 10

I have had a problem running a project in an android emulator on windows 10. I have tried running the project on a android device and it works fine, will also run on an emulator in Android Studio.
I get the following error message, can you help?

Waiting for emulator to start…
(node:7588) UnhandledPromiseRejectionWarning: CordovaError: Failed to execute shell command “getprop,dev.bootcomplete”" on device: Error: C:\Users_user_
\AppData\Local\Android\Sdk\platform-tools\adb.exe: Command failed with exit code 1 Error output:
error: device still connecting
at T:\Wappler Apps\Demo\platforms\android\cordova\lib\Adb.js:88:25
at _rejected (T:\Wappler Apps\Demo\platforms\android\cordova\node_modules\q\q.js:864:24)
at T:\Wappler Apps\Demo\platforms\android\cordova\node_modules\q\q.js:890:30
at Promise.when (T:\Wappler Apps\Demo\platforms\android\cordova\node_modules\q\q.js:1142:31)
at Promise.promise.promiseDispatch (T:\Wappler Apps\Demo\platforms\android\cordova\node_modules\q\q.js:808:41)
at T:\Wappler Apps\Demo\platforms\android\cordova\node_modules\q\q.js:624:44
at runSingle (T:\Wappler Apps\Demo\platforms\android\cordova\node_modules\q\q.js:137:13)
at flush (T:\Wappler Apps\Demo\platforms\android\cordova\node_modules\q\q.js:125:13)
at process._tickCallback (internal/process/next_tick.js:150:11)
(node:7588) UnhandledPromiseRejectionWarning: Unhandled promise rejection. This error originated either by throwing inside of an async function withou
t a catch block, or by rejecting a promise which was not handled with .catch(). (rejection id: 1)
(node:7588) [DEP0018] DeprecationWarning: Unhandled promise rejections are deprecated. In the future, promise rejections that are not handled will ter
minate the Node.js process with a non-zero exit code.
Error emulating your Cordova Project for android!

There is a bug in the Cordova android tools about this. They solved it in their code base but i’m Not sure if it is published yet.

You can try the latest v 7.1.1


Hi George,

I tried your suggestion but it did not make any difference however I did find a solution that fixed the problem, see the following link;

https://stackoverflow.com/a/51079689 which made a change to the emulator.js file.

Also I notice that the build gradle is using gradle 4.1.

I have tried changing the line in the gradle-wrapper.properties file from distributionUrl=https://services.gradle.org/distributions/gradle-4.1-all.zip

to use gradle-4.6-all.zip but at the build it changes it back to 4.1.

I tried the build in Android Studio with 4.6 and it was fine, but as soon as I took it back into Wappler it changed it back to 4.1

Any suggestions on how to get it to use the lastest gradle?

Cheers Mark