Electron not visible as option for Desktop Apps

following the tutorial and when I set up the template electron is not a choice in platforms. I noticed that the index.html that is created only says “body” not “app” and the expected frameworks are not included.

Please make sure you have the latest Cordova 9

There is a Cordova update button in the publishing toolbar in Wappler.

image

May sound a basic question but have you added them from here?

Adding local App connect should change the prompt from Body to App

I did. It also shows in the project options.

I updated cordova and electron still does not set up.

It’s not a big deal I was just testing it

Did you do system check and which node and Cordova versions it returns?

I did not. I ran the update process and it just said it suceeded. I just now ran the system check and it says 8.1.2 despite showing 9.0.0 in the project settings. I retried the update with the same result

Just make sure you have at least NodeJS 10, you can run the installer from:

Make sure you restart Wappler after the installation.

Then upgrade Cordova from within Wappler:

As stated above:
image

Till it shows Cordova 9 in the system check

ok. I tried again and this update info appeared in the platform window , unfortunately the update fails. Do you want to see the log?

Hi Rodney,

You really should update to the latest NodeJS (at least ver 10) and also make sure you are on Cordova 9 as well. You can check the versions in the system check.

Also see Unable to start a mobile project - npm permissions - although it is more a Mac permissions problem there