Dynamic Video URL Does not load but static does

Wappler Version : 6.5.5 but believe this is since 6.5
Operating System : Windows 11
Server Model: Apache
Database Type: MySQL
Hosting Type: Azure App Service

Expected behavior

Click the play control and the video plays

Actual behavior

Click the play control and nothing plays. However, if I set the URL to static it will play. This did work prior to 6.5

This works
image

This does not
image

Thought maybe the URL has to be encoded since 6.5 and that did not work.

Your src looks wrong/incomplete to me ... when I had a source it looks like this:

dmx-bind:src="score.data.query.score1"

Or are you within a repeat regiaon?

Its part of a masonry.. We have a masonry that shows all the videos from a DB.

Hmmm, and you are sure your serverconnect is returning results?

What if you wrapped the bindng in curly brackets like:

dmx-bind:src="{{vid_url}}"

Also, does your vid_url value in the database include the whole path or just the video file name?

Tried the brackets, nothing. The server connect is returning the results. I know this because its also returning the data from other columns in the tables. It returned three lines, and created three columns as part of the masony. All the text is dynamic. What I did notice is the URL is returned like this? I tried encoding, not sure if that has anything to do with it. Just odd that it started after 6.5


image

Do you see any errors in the browser console?
Can you also paste your full masonry code here, (not a screenshot but the code itself) or provide a link to this page.

Console is always my first go to. No errors. Here is the code and thank you for your time on this.

<div class="row mb-5 ps-2 pe-2" is="dmx-masonry" id="masonry2" dmx-bind:repeat="qry_training_videos.data.qry_videos" key="id_training_vid" columns="1" columns-sm="1" columns-md="3" columns-lg="4" columns-xl="5" preserve-order="true" dmx-show="qry_training_videos.data.qry_videos.hasItems()">


					<div class="col border border-dark pt-2 bg-secondary-subtle">
						<div class="row g-0 rounded-0 border border-dark">
							<div class="col bg-info pb-0 rounded-0 border-dark border-bottom">
								<h6 class="text-start text-light mt-1 pt-0 ps-1">{{vid_title}} </h6>
								<div class="row g-0 bg-light"><video is="dmx-video" id="video1" width="100%" preload="none" height="400" controls="true" autopause="true" dmx-bind:src="{{vid_url}}">

									</video>
								</div>

							</div>
						</div>

						<div class="row">
							<div class="col">
								<h6 class="text-start text-danger" dmx-show="vid_required==1">REQUIRED CONTENT</h6>
							</div>
							<div class="col-4">
								<h6 class="text-end text-muted">PLAYS : {{vid_plays}}</h6>
							</div>
						</div>
						<div class="row">
							<div class="col">
								<h6 class="text-success text-start" dmx-show="(vid_log_completed == 1)">COMPLETED {{vid_log_ended.formatDate('MM/dd/yyyy hh:mm')}}</h6>
								<h6 class="text-warning text-start" dmx-show="vid_log_completed==0&amp;&amp;vid_position>=1">IN PROGRESS {{vid_log_started.formatDate('MM/dd/yyyy hh:mm')}}</h6>

							</div>
						</div>

						<h6 class="text-start">{{vid_notes}}</h6>
						<h6 class="text-start small text-secondary" dmx-show="vid_content_link.startsWith('/')" dmx-on:click="browserTop.goto(vid_content_link)"><i class="fa-solid fa-folder-arrow-down me-2"></i> Available Training Material</h6>
					</div>
				</div>

Can you share a link where we can check your page?

Its hosted on Azure App Service and we use conditional access and Intune to keep everything locked down and secure. Sorry I know that does not make this easy.

if static(relative) url works but dynamic(relative) url don't work..
it looks to me that dmx-bind is not translated correctly (form relative to absolute url)
Can you try that:

  1. run the page with the whole url as static("https://mydomain.com/path/xbxbxb/video.mov")
  2. Save the whole video url("https://mydomain.com/path/xbxbxb/video.mov") in your data sourse and run again
    Compare in the online code how is the video source translated in each of the above 2 cases?
    (I don't know if the above test will make sure that the relative url is translated correctly... Any other idea would be welcome)

I did try the complete URL. Same result. When I click the video that has a static URL, I can see the video gets loaded. When I click the dynamic, nothing gets loaded, no attempt, nothing, not even console. Its like the controls are locked.

1 Like

What about the network tab?
Inspect > network > reload
Then you'll see the status of the files

I have the same exact result, I had to revert my video component to the 1.0 version.

Static works fine, black box with locked controls for dynamics on the 2.0 version

1 Like

Confirmed going back to 1.02 of DMXVideo worked for me to. Thank you!

1 Like

Have an update ready for testing: dmxVideo.zip (2.3 KB)

1 Like

That does the trick for me :slight_smile:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.