Dynamic Select Lists broken (BETA Channel)

Wappler Version : 5.7.0
Operating System : Ubuntu
Server Model: Node/Docker
Database Type:
Hosting Type: Digital Ocean

Expected behaviour

What do you think should happen?

Should be able to have a default value such as ‘Select Type’ and the dynamic data appearing below the default.

Actual behaviour

What actually happens?

The default value ‘Select Type’ flashes briefly and is then replaced by the dynamic data populating the Select List.

How to reproduce

  • Create Select List.
  • Add the default value.
  • Convert to Dynamic Select.
  • Default value flashes and disappears.

This has worked fine for years but now causes issues with all of our Projects as all use default values in the Select Lists if none are set. Please fix, aside from that 5.7.0 for us would be GREAT! But currently had to revert back to Stable Channel. Bummer.

Please provide a screenshot of what you see exactly. Also please provide your select menu code.

Beta channel means - NOT READY FOR PRODUCTION, which means - you have to be careful where you are using the BETA extensions, it’s not recommended to deploy to production without testing.

Hence the bug report and our decision to roll back our Wappler version to a stable release where everything works correctly.

Well … “It doesn’t work, so we reverted back” doesn’t really help us.
Proper bug reports help us identify the issues, so we need more details what’s wrong there.

This is the bug report Teodor! There is nothing else to it.

A select list with a default value:

<option selected="" value="">Select Region</option></select>

Bound to dynamic data:

<select id="traderRegion" class="form-select form-select-lg formFields border rounded" required="" name="traderRegion" dmx-bind:options="content.selectRegion.data.selectRegion" optiontext="regionTitle" optionvalue="regionUUID">
                                    <option selected="" value="">Select Region</option></select>

No longer shows the default selected value. It only shows the dyanmic data for the select list, and briefly flashes the selected value ‘Select Region’. This has always worked fine until recently.

1 Like

I do apologies. The most stressful day here. Not had one like this for many years. I should not take it out on you Teodor, sorry for the that!