Dynamic Events: missing actions when submitting forms

It seems there is a serious problem when choosing dynamic events after submitting a form (and perhaps in other situations) - most options are missing from the Available Actions panel.

I noticed some form fields were not being reset after a form was submitted and looked at what actions had been added. The reset had been included (but doesn’t seem to be working - but that’s another issue), but there was no way of adding this option (obviously there was when I added it). In fact most of the options were missing. The form is in a modal and these are the available actions:


All the actions related to the form are missing. I thought I must be getting confused about how this worked, so I copied the files onto a computer which still has version 1.4, and these are the available actions:

I noticed the problem on a Windows 10 computer. The computer with the old version is a Mac. Have others come across this? I don’t think it’s a problem with these specific files. I created a new form, not in a modal - same problem.

Thanks for the report, will investigate. We’ve made some changes in that area indeed in 1.5 but it was about to see more and not less :slight_smile:

So I will check it out


Thanks George. The more part is generally a great improvement and I’m sure you’ll fix the less soon.

I am having the same issue, unable to see any available actions to select. Thanks.

@ajansen - maybe you don’t have actions to pick up from? As I see you have moved a lot of the components to an include file - they become then invisible to the current file

In my case, I’m using just one include file for the header. As I mentioned, the same file shows all the actions I would expect, using version Wappler 1.4; in 1.5 they’ve disappeared.

@George - do you see all the actions as expected - eg when including a Server Connect form?

I’ve just tried with another site, with a page which has no includes. Again most of the expected actions to choose from have disappeared. However, there was a slight difference which might be a clue: the checkbox elements included in the form appear (the form actually includes over 20 fields):


1 Like

Hi George, I don’t have much in the include file, just the menu, so I don’t think that is the issue. Thank you. AJ

Yes I can confirm, actions which where available in 1.4 are now gone. More specifically, all text inputs in the serverconnect forms. All other form elements are still available with all options.

Confirming the same issue here. I thought it was just me losing the plot.

Am also having trouble selecting tags contained within tags but in Dreamweaver, since the last update… Reported here: https://www.dmxzone.com/support/32763/topic/64586/

Another weird one below. I’m sure I could add Dynamic Events etc to links in the past but in this case all is acting very weird and seems to be selecting the wrong tags…

2018-10-27_23-34-32.mp4 (1.9 MB)

1 Like

This has been fixed in version 1.5.2

1 Like