Deployment to Digital Ocean Missing Files

I have an app that works well in local dev docker, I just deployed it to a Digital Ocean Droplet and the login page loads correctly, but when I try to login, I get the attached errors.

I’ve tried updating and redeploying but no luck. I tried to navigate to /var/www/ through the digital ocean console to verify the files were there, but I’m clearly not looking in the correct spot cause there is nothing in the var folder I can find so it must be a different one.

Thanks in advance,

Wappler deployments to DO do not upload your actual files like assets etc, you need to manually push them by going to the file section and hitting upload while in your production target (bottom left)

DB changes work the same way, make sure you change target to production and then apply your latest changes.

Hope this helps

1 Like

Ok I feel stupid now haha. Thanks for the quick response. I guess I was thinking they sync’d automatically when deployed.

1 Like

Haha glad I could help I did the exact same thing took me a while to realize it as well

Ok now I’m trying to figure out how to set your answer at the solution…one of those days…haha

Try now, I moved your topic to the How to section

1 Like

Thank you, that did it.

1 Like