Datepicker only works in Safari

Love, love, love the new date picker - and so easy to use - 1 click and it is working :slight_smile:

1 Like

Not sure why - works great when I access via Safari but does not seem to work when accessed via Firefox or Chrome - has anyone else noticed this?

FYI, does not seem to work via my IPAD (IOS) in Safari and it did not work on my wife’s android tablet (she uses chrome on her tablet).

I don’t have a Windows machine handy to see if that works - should I file a bug report or am I missing something simple…

PS. Works on my wife’s desktop but only in Safari…

Works fine for me unless I apply a format mask - then it breaks.

I don’t have any formatting applied - doing my build on a mac - not sure what the issue is?

I'm on a Mac as well. Here is my test page:

Yes I tried it on your page and I see it only works in the unformatted box - have you tried it from anything besides Safari - it works great in Safari but nowhere else.

My page below

I tried mine with Safari, Chrome and Firefox. Works fine without any format mask. Yours however does not work. Wonder if you have something conflicting.

Interesting - I do have a dark cloud that generally follows me around :slight_smile:

But I doubt anything special is going on - the info is only used in the print out - not saved or anything.

Chad has been helping me - I just started learning about two weeks ago - so it is likely just something stupid I have done (or that I’m not doing)…

Thanks for taking a look - I appreciate it …

Well I looked at Brads code and noticed I had my input top set to date and his was text - changed mine to text and it is working now (I have not tried to specify a format so not sure about that)

Total newbie mistake I guess :slight_smile:

Hello @norcoscia ,
The datepicker input should be a text field, it should not be changed to a date field.

1 Like

Thanks Teodor that is what I figured once I got it working - thanks for adding it!

1 Like