Database Server connection error

If you have setup your database connection from within server connnect, then you should uncheck the Use Direct Connection in the database manager, that should probably fix the the unable to connect error there.

Hi Patrick,

It’s been unchecked this whole time.

The error I am getting is “ER_NOT_SUPPORTED_AUTH_MODE: Client does not support authentication protocol requested by server; consider upgrading MySQL client.”

I am currently running the following database setup:

  • Server: Localhost via UNIX socket
  • Server type: MySQL
  • Server connection: SSL is not being used
  • Server version: 5.7.31 - MySQL Community Server (GPL)
  • Protocol version: 10
  • Server charset: cp1252 West European (latin1)

Thanks,

Are you sure it is MySQL 5.7 that is running on the server, the error is normally something you get with MySQL 8.0.

Yep - the details I shared with you was directly from MyPHPAdmin and I went and verified on the backend with WHM and it is 5.7.

Thanks,

Thoughts?

Anyone?

Well a google search reveals that maybe your MySQL server needs a bit more configuration:

This applies to people running on 8.0 unfortunately. It seems my server is not compatible with Wappler… Do you have any recommended solutions for hosting my database that are proven? I’d love top get to developing .

I never have seen that error with a MySQL 5.7 Server, are you sure you have setup the database connection to the correct server?

Yes, I am running my different domains on my own WHM + cPanel setup. I created a brand new DB with a new subdomain with logins and credentials just for this.

Anyone have any other ideas?

Wappler uses standard PHP PDO library to connect to your MySQL server.

It can not connect because of the configuration and MySQL 8 version that you are using.

The answer was given above and has little to do with Wappler actually. It is just your server configuration.

Hi George,

I’ve been very clear that my server is not running on 8.0. I have verifies both on admin server configuration and domain specific server configuration and even within the database itself. It is all 5.7.

This puts it back in your ballpark.

Thanks,

All of my domains hosted on my server are using WordPress and the same fix you provided to me for MySQL 8 would need to be completed for WordPress if my server was 8.0 however I haven’t had to do that as it’s 5.7.

I know this as I was considering upgrading to 8.0 when this problem started so I researched the comparability with WordPress and wappler and found both had compatibility issues so I didn’t upgrade it.

Thanks,

Lets go over the problem one more time. In the very first post you had an error with the login, no database error there. The Database Manager showed the Unable to Connect message but when testing the connection it says that it is OK.

You then removed all server connections and the dmxConnectLib folder and create a new server action. Database Manager still shows the Unable to Connect and you are getting an ER_NOT_SUPPORTED_AUTH_MODE error.

Does your database server support remote connections? This is only important for the Database Manager since it connects to the database directly. You need to use the remote ip/host address, so not localhost. Set the connection using the Direct Database Connection.

Also important is that the correct target is selected. The Server Connect Connection runs on the server, here you normally use localhost and is run from php. This connection settings is used in the server actions, not in the Database Manager.

I think that you use the Server Connect settings in the Database Manager with localhost and you probably have a MySQL 8 running on your localhost.

I was just having this problem and I did what Teodor suggested and that seems to work. I deleted the folder from local and server folders.

Hi Patrick,

Your final assessment was correct - with the localhost configuration and the not enabled remote access for my IP on server. However I was not running on MySQL 8.

It’s working now.

Thanks!