Database Connection Error - Access denied for user

I read an identical topic, but my issue wasn’t resolved by following the steps that fixed it for them.

When I try to establish a database connection, I get the following error:
Error connecting: Access denied for user ‘username’@‘’ (using password: YES)

My credentials are correct and the connection is working fine in Dreamweaver.

Database type: Custom
Database: MySQL/MariaDB
Host: My host IP
User: [username]
Password: [password]
Database: [database name]

I don’t have SSL or SSH on. The FTP connection required the database info to be filled out (?), and that is working correctly.

Any ideas?

Hi Aysling, welcome to Wappler. Usually this happens when:

1: A username or password is entered incorrectly (or other setting)
2: Your host doesn’t allow remote connections (most likely)

If you use a. third party database app like BeeKeeper, Navicat or MySQL Workbench can you connect?

Also, I assume ‘username’ in your error message has been changed from your actual username?

1 Like

I figured it out! Accidentally pasted an extra ’ ’ in my username.

1 Like

Great, good luck with your Wappler Journey.

1 Like