Custom query text selection issue

======== TEMPLATE BUG FORM ========

Wappler Version : 3.00 RC3
Operating System : Windows 10

Expected behavior

The selected text in a custom query should be visually apparent.

Actual behavior

The selection highlight does not accurately indicate what is selected.

Eg I have selected the whole query in order to paste it into another custom query:


From the appearance, it seems the text is not all selected, but it is - it is all transferred following a paste. Selecting with the mouse or Ctrl+A produces the same result.

A very minor issue, but appearing like this, you would assume the text is not correctly selected.

Where does this happen, where exactly are you editing?

It’s the Database Custom Query window, in the area where you enter the code (having clicked the ‘Build Query’ button under Database Custom Query Properties).

I tried pasting the same query into a new server action, and the selection works. There must be something specific to the server action which is causing this. It might be difficult to track down, but as I say, it’s a very minor issue. I’ll let you know if I find any clues or if it happens again.