CSS file issue

Thanks for reporting an issue! Spend 60 seconds reading this…

======== TEMPLATE BUG FORM ========

Wappler Version : 2.2.5
Operating System : Windows 10

Expected behavior

What do you think should happen?

When I make a modification in the Design panel it create a new class and it should be added to the user CSS file even if the css file is not open in the editor.

Actual behavior

What actually happens?

Now I have to open the user CSS file in the editor so the modifications are added to the css user file.

How to reproduce

  1. I create a new project
  2. Attach the user css file
  3. Create a new page
  4. Put a new element on the page (let say a row)
  5. Add top padding of 20px on that row
  6. I see the modification in the design view (ok)
  7. It create a new css class in deisgn panel class like supposed to (image #1)
  8. BUT The new class is not added to the user CSS file (image #2)

Now with the css user file open in the editor:
I do the same steps as below but now the new class is added to the css file (image#3)

Note1: This is not happening with older project (before 2.2.4 or 2.2.5)

Note2: After around 30 minutes of work I have to close/open Wappler because it stop saving the user css file.

Do you have experimental features turned on or off? Try turning it on/off and see if that makes a difference.

Thank you Patrick for the quick reply.

Experimental features was turned on.

So I turned it off (and user css file is not open in editor) and now it is somehow the opposite problem: Now the modifications I make in design panel does indeed reflect in the style panel but it does not modifiy the actuel design, for example I changed the padding of some element and nothing happen in the design view.

But when the user css file is open in editor the changes does work.well.

Hello @Webjack357. Thanks for this thread. I am having the same issue since I updated to 2.2.5 last week. When I add or edit a new style the custom css file is not updated, but when it is opened the changes are added to it as well.

1 Like

I think we identified the problem and it should be fixed in today’s Wappler update. Let us know if the problem still persists after the update.

1 Like

Hello and welcome Moustapha. The good news with Wappler is that the dev team is very fast to size and fix issues, that kind of dedication and support is rare these days :slight_smile: