Connecting to SFTP with PPK key

#1

Hello Teodor,

When connecting to the webserver via Filezilla, I reference a local ‘rd-rsa.ppk’ file and have the enter the password before I attempt to connect. After that, I am able to connect to the host in the usual way.

In Wappler, I’ve entered the following but see permission denied each time.

The password I need to enter for the '‘rd-rsa.ppk’ is different to the web host password. As I am not being asked for the first password, I wondered if this was the problem?

Thanks and best regards,
Brian

#2

Hi Brian,

Well just press the “Test Connection” button and you should see more detailed info.
If still not clear you can copy and paste the output here, it will be anonymized when you use the copy button

#3

Hello George,

You guys are up late tonight.

I have pasted the log below but its Friday and I’m happy to wait until next week.

Testing Connection …

  • set color:use-color yes
  • set cmd:interactive yes
  • set file:charset utf-8
  • set xfer:clobber on
  • set ftp:timezone
  • set cmd:show-status yes
  • set cmd:set-term-status yes
  • set ftp:list-options -a
  • set cmd:fail-exit yes
  • set cmd:time-style “%Y-%m-%d %H:%M:%S”
  • set ftp:ssl-allow no
  • set ssl:verify-certificate no
  • set sftp:auto-confirm yes
  • set sftp:connect-program “ssh -a -x -v -i /Users/user/.ssh/mysite.com
  • set net:max-retries 3
  • set net:timeout 20
  • set net:reconnect-interval-base 5
  • set net:reconnect-interval-multiplier 1
  • open -u user,pass sftp://mysite.com
  • ls
    ---- Running connect program (ssh -a -x -v -i /Users/user/.ssh/mysite.com -s -l user mysite.com sftp)
    —> sending a packet, length=5, type=1(INIT), id=0
    <— OpenSSH_7.8p1, LibreSSL 2.6.2
    <— debug1: Reading configuration data /etc/ssh/ssh_config
    <— debug1: /etc/ssh/ssh_config line 48: Applying options for *
    <— debug1: Connecting to mysite.com port 22.
    <— debug1: Connection established.
    <— debug1: identity file /Users/user/.ssh/mysite.com type 0
    <— debug1: identity file /Users/user/.ssh/mysite.com type -1
    <— debug1: Local version string SSH-2.0-OpenSSH_7.8
    <— debug1: Remote protocol version 2.0, remote software version OpenSSH_7.4
    <— debug1: match: OpenSSH_7.4 pat OpenSSH_7.0*,OpenSSH_7.1*,OpenSSH_7.2*,OpenSSH_7.3*,OpenSSH_7.4*,OpenSSH_7.5*,OpenSSH_7.6*,OpenSSH_7.7* compat 0x04000002
    <— debug1: Authenticating to mysite.com as ‘user
    <— debug1: SSH2_MSG_KEXINIT sent
    <— debug1: SSH2_MSG_KEXINIT received
    <— debug1: kex: algorithm: curve25519-sha256
    <— debug1: kex: host key algorithm: ecdsa-sha2-nistp256
    <— debug1: kex: server->client cipher: mysite.com MAC: compression: none
    <— debug1: kex: client->server cipher: mysite.com MAC: compression: none
    <— debug1: expecting SSH2_MSG_KEX_ECDH_REPLY
    <— debug1: Server host key: ecdsa-sha2-nistp256 SHA256:FI1HsDT8Exu55VGrkwyUpoIToPckiHLI3/MpDl7bims
    <— debug1: Host ‘mysite.com’ is known and matches the ECDSA host key.
    <— debug1: Found key in /Users/user/.ssh/known_hosts:35
    <— debug1: rekey after 134217728 blocks
    <— debug1: SSH2_MSG_NEWKEYS sent
    <— debug1: expecting SSH2_MSG_NEWKEYS
    <— debug1: SSH2_MSG_NEWKEYS received
    <— debug1: rekey after 134217728 blocks
    <— debug1: SSH2_MSG_EXT_INFO received
    <— debug1: kex_input_ext_info: server-sig-algs=<rsa-sha2-256,rsa-sha2-512>
    <— debug1: SSH2_MSG_SERVICE_ACCEPT received
    <— debug1: Authentications that can continue: publickey,gssapi-keyex,gssapi-with-mic
    <— debug1: Next authentication method: publickey
    <— debug1: Offering public key: RSA SHA256:2YgLrz4QudC98WpJUtUqvNW6BHnAAzsBGNAsagIMDoo /Users/user/.ssh/mysite.com
    <— debug1: Server accepts key: pkalg rsa-sha2-512 blen 279
    <— @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
    <— @ WARNING: UNPROTECTED PRIVATE KEY FILE! @
    <— @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
    <— Permissions 0644 for ‘/Users/user/.ssh/mysite.com’ are too open.
    <— It is required that your private key files are NOT accessible by others.
    <— This private key will be ignored.
    <— Load key “/Users/user/.ssh/mysite.com”: bad permissions
    <— debug1: No more authentication methods to try.
    <— user****mysite.com Permission denied (publickey,gssapi-keyex,gssapi-with-mic).
    **** Peer closed connection
    ---- Disconnecting
    ls' at 0 [**user****mysite.com** Permission denied (publickey,ls’ at 0 ---- Running connect program (ssh -a -x -v -i /Users/user/.ssh/mysite.com -s -l user mysite.com sftp)
    —> sending a packet, length=5, type=1(INIT), id=0
    <— OpenSSH_7.8p1, LibreSSL 2.6.2
    <— debug1: Reading configuration data /etc/ssh/ssh_config
    <— debug1: /etc/ssh/ssh_config line 48: Applying options for *
    <— debug1: Connecting to mysite.com port 22.
    <— debug1: Connection established.
    <— debug1: identity file /Users/user/.ssh/mysite.com type 0
    <— debug1: identity file /Users/user/.ssh/mysite.com type -1
    <— debug1: Local version string SSH-2.0-OpenSSH_7.8
    <— debug1: Remote protocol version 2.0, remote software version OpenSSH_7.4
    <— debug1: match: OpenSSH_7.4 pat OpenSSH_7.0*,OpenSSH_7.1*,OpenSSH_7.2*,OpenSSH_7.3*,OpenSSH_7.4*,OpenSSH_7.5*,OpenSSH_7.6*,OpenSSH_7.7* compat 0x04000002
    <— debug1: Authenticating to mysite.com as ‘user
    <— debug1: SSH2_MSG_KEXINIT sent
    <— debug1: SSH2_MSG_KEXINIT received
    <— debug1: kex: algorithm: curve25519-sha256
    <— debug1: kex: host key algorithm: ecdsa-sha2-nistp256
    <— debug1: kex: server->client cipher: mysite.com MAC: compression: none
    <— debug1: kex: client->server cipher: mysite.com MAC: compression: none
    <— debug1: expecting SSH2_MSG_KEX_ECDH_REPLY
    <— debug1: Server host key: ecdsa-sha2-nistp256 SHA256:FI1HsDT8Exu55VGrkwyUpoIToPckiHLI3/MpDl7bims
    <— debug1: Host ‘mysite.com’ is known and matches the ECDSA host key.
    <— debug1: Found key in /Users/user/.ssh/known_hosts:35
    <— debug1: rekey after 134217728 blocks
    <— debug1: SSH2_MSG_NEWKEYS sent
    <— debug1: expecting SSH2_MSG_NEWKEYS
    <— debug1: SSH2_MSG_NEWKEYS received
    <— debug1: rekey after 134217728 blocks
    <— debug1: SSH2_MSG_EXT_INFO received
    <— debug1: kex_input_ext_info: server-sig-algs=<rsa-sha2-256,rsa-sha2-512>
    <— debug1: SSH2_MSG_SERVICE_ACCEPT received
    <— debug1: Authentications that can continue: publickey,gssapi-keyex,gssapi-with-mic
    <— debug1: Next authentication method: publickey
    <— debug1: Offering public key: RSA SHA256:2YgLrz4QudC98WpJUtUqvNW6BHnAAzsBGNAsagIMDoo /Users/user/.ssh/mysite.com
    <— debug1: Server accepts key: pkalg rsa-sha2-512 blen 279
    <— @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
    <— @ WARNING: UNPROTECTED PRIVATE KEY FILE! @
    <— @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
    <— Permissions 0644 for ‘/Users/user/.ssh/mysite.com’ are too open.
    <— It is required that your private key files are NOT accessible by others.
    <— This private key will be ignored.
    <— Load key “/Users/user/.ssh/mysite.com”: bad permissions
    <— debug1: No more authentication methods to try.
    <— user****mysite.com Permission denied (publickey,gssapi-keyex,gssapi-with-mic).
    **** Peer closed connection
    ---- Disconnecting
    ls' at 0 [**user****mysite.com** Permission denied (publickey,ls’ at 0 ---- Running connect program (ssh -a -x -v -i /Users/user/.ssh/mysite.com -s -l user mysite.com sftp)
    —> sending a packet, length=5, type=1(INIT), id=0
    <— OpenSSH_7.8p1, LibreSSL 2.6.2
    <— debug1: Reading configuration data /etc/ssh/ssh_config
    <— debug1: /etc/ssh/ssh_config line 48: Applying options for *
    <— debug1: Connecting to mysite.com port 22.
    <— debug1: Connection established.
    <— debug1: identity file /Users/user/.ssh/mysite.com type 0
    <— debug1: identity file /Users/user/.ssh/mysite.com type -1
    <— debug1: Local version string SSH-2.0-OpenSSH_7.8
    <— debug1: Remote protocol version 2.0, remote software version OpenSSH_7.4
    <— debug1: match: OpenSSH_7.4 pat OpenSSH_7.0*,OpenSSH_7.1*,OpenSSH_7.2*,OpenSSH_7.3*,OpenSSH_7.4*,OpenSSH_7.5*,OpenSSH_7.6*,OpenSSH_7.7* compat 0x04000002
    <— debug1: Authenticating to mysite.com as ‘user
    <— debug1: SSH2_MSG_KEXINIT sent
    <— debug1: SSH2_MSG_KEXINIT received
    <— debug1: kex: algorithm: curve25519-sha256
    <— debug1: kex: host key algorithm: ecdsa-sha2-nistp256
    <— debug1: kex: server->client cipher: mysite.com MAC: compression: none
    <— debug1: kex: client->server cipher: mysite.com MAC: compression: none
    <— debug1: expecting SSH2_MSG_KEX_ECDH_REPLY
    <— debug1: Server host key: ecdsa-sha2-nistp256 SHA256:FI1HsDT8Exu55VGrkwyUpoIToPckiHLI3/MpDl7bims
    <— debug1: Host ‘mysite.com’ is known and matches the ECDSA host key.
    <— debug1: Found key in /Users/user/.ssh/known_hosts:35
    <— debug1: rekey after 134217728 blocks
    <— debug1: SSH2_MSG_NEWKEYS sent
    <— debug1: expecting SSH2_MSG_NEWKEYS
    <— debug1: SSH2_MSG_NEWKEYS received
    <— debug1: rekey after 134217728 blocks
    <— debug1: SSH2_MSG_EXT_INFO received
    <— debug1: kex_input_ext_info: server-sig-algs=<rsa-sha2-256,rsa-sha2-512>
    <— debug1: SSH2_MSG_SERVICE_ACCEPT received
    <— debug1: Authentications that can continue: publickey,gssapi-keyex,gssapi-with-mic
    <— debug1: Next authentication method: publickey
    <— debug1: Offering public key: RSA SHA256:2YgLrz4QudC98WpJUtUqvNW6BHnAAzsBGNAsagIMDoo /Users/user/.ssh/mysite.com
    <— debug1: Server accepts key: pkalg rsa-sha2-512 blen 279
    <— @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
    <— @ WARNING: UNPROTECTED PRIVATE KEY FILE! @
    <— @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
    <— Permissions 0644 for ‘/Users/user/.ssh/mysite.com’ are too open.
    <— It is required that your private key files are NOT accessible by others.
    <— This private key will be ignored.
    <— Load key “/Users/user/.ssh/mysite.com”: bad permissions
    <— debug1: No more authentication methods to try.
    <— user****mysite.com Permission denied (publickey,gssapi-keyex,gssapi-with-mic).
    **** Peer closed connection
    **** user****mysite.com Permission denied (publickey,gssapi-keyex,gssapi-with-mic).
    ---- Disconnecting
    ls: Fatal error: max-retries exceeded (user****mysite.com Permission denied (publickey,gssapi-keyex,gssapi-with-mic).)

Have a great weekend,

Best regards,
Brian

#4

Seems to me you have a key problem Brian

#5

Certainly not an expert here but perhaps permissions 644 (read / write) needs to be 444 (read only)?

Just a guess

#6

Hi Brian, George,

Sorry, I pasted in the wrong…

Testing Connection …

  • set color:use-color yes
  • set cmd:interactive yes
  • set file:charset utf-8
  • set xfer:clobber on
  • set ftp:timezone
  • set cmd:show-status yes
  • set cmd:set-term-status yes
  • set ftp:list-options -a
  • set cmd:fail-exit yes
  • set cmd:time-style “%Y-%m-%d %H:%M:%S”
  • set ftp:ssl-allow no
  • set ssl:verify-certificate no
  • set sftp:auto-confirm yes
  • set sftp:connect-program “ssh -a -x -v -i /Users/user/.ssh/mysite.com
  • set net:max-retries 3
  • set net:timeout 20
  • set net:reconnect-interval-base 5
  • set net:reconnect-interval-multiplier 1
  • open -u user,pass sftp://mysite.com
  • ls
    ---- Running connect program (ssh -a -x -v -i /Users/user/.ssh/mysite.com -s -l user mysite.com sftp)
    —> sending a packet, length=5, type=1(INIT), id=0
    <— OpenSSH_7.8p1, LibreSSL 2.6.2
    <— debug1: Reading configuration data /etc/ssh/ssh_config
    <— debug1: /etc/ssh/ssh_config line 48: Applying options for *
    <— debug1: Connecting to mysite.com port 22.
    <— debug1: Connection established.
    <— debug1: identity file /Users/user/.ssh/mysite.com type -1
    <— debug1: identity file /Users/user/.ssh/mysite.com type -1
    <— debug1: Local version string SSH-2.0-OpenSSH_7.8
    <— debug1: Remote protocol version 2.0, remote software version OpenSSH_7.4
    <— debug1: match: OpenSSH_7.4 pat OpenSSH_7.0*,OpenSSH_7.1*,OpenSSH_7.2*,OpenSSH_7.3*,OpenSSH_7.4*,OpenSSH_7.5*,OpenSSH_7.6*,OpenSSH_7.7* compat 0x04000002
    <— debug1: Authenticating to mysite.com as ‘user
    <— debug1: SSH2_MSG_KEXINIT sent
    <— debug1: SSH2_MSG_KEXINIT received
    <— debug1: kex: algorithm: curve25519-sha256
    <— debug1: kex: host key algorithm: ecdsa-sha2-nistp256
    <— debug1: kex: server->client cipher: mysite.com MAC: compression: none
    <— debug1: kex: client->server cipher: mysite.com MAC: compression: none
    <— debug1: expecting SSH2_MSG_KEX_ECDH_REPLY
    <— debug1: Server host key: ecdsa-sha2-nistp256 SHA256:FI1HsDT8Exu55VGrkwyUpoIToPckiHLI3/MpDl7bims
    <— debug1: Host ‘mysite.com’ is known and matches the ECDSA host key.
    <— debug1: Found key in /Users/user/.ssh/known_hosts:35
    <— debug1: rekey after 134217728 blocks
    <— debug1: SSH2_MSG_NEWKEYS sent
    <— debug1: expecting SSH2_MSG_NEWKEYS
    <— debug1: SSH2_MSG_NEWKEYS received
    <— debug1: rekey after 134217728 blocks
    <— debug1: SSH2_MSG_EXT_INFO received
    <— debug1: kex_input_ext_info: server-sig-algs=<rsa-sha2-256,rsa-sha2-512>
    <— debug1: SSH2_MSG_SERVICE_ACCEPT received
    <— debug1: Authentications that can continue: publickey,gssapi-keyex,gssapi-with-mic
    <— debug1: Next authentication method: publickey
    <— debug1: Trying private key: /Users/user/.ssh/mysite.com
    <— Load key “/Users/user/.ssh/mysite.com”: invalid format
    <— debug1: No more authentication methods to try.
    <— user****mysite.com Permission denied (publickey,gssapi-keyex,gssapi-with-mic).
    **** Peer closed connection
    **** user****mysite.com Permission denied (publickey,gssapi-keyex,gssapi-with-mic).
    ---- Disconnecting
    ls' at 0 [**user****mysite.com** Permission denied (publickey,ls’ at 0 ---- Running connect program (ssh -a -x -v -i /Users/user/.ssh/mysite.com -s -l user mysite.com sftp)
    —> sending a packet, length=5, type=1(INIT), id=0
    <— OpenSSH_7.8p1, LibreSSL 2.6.2
    <— debug1: Reading configuration data /etc/ssh/ssh_config
    <— debug1: /etc/ssh/ssh_config line 48: Applying options for *
    <— debug1: Connecting to mysite.com port 22.
    <— debug1: Connection established.
    <— debug1: identity file /Users/user/.ssh/mysite.com type -1
    <— debug1: identity file /Users/user/.ssh/mysite.com type -1
    <— debug1: Local version string SSH-2.0-OpenSSH_7.8
    <— debug1: Remote protocol version 2.0, remote software version OpenSSH_7.4
    <— debug1: match: OpenSSH_7.4 pat OpenSSH_7.0*,OpenSSH_7.1*,OpenSSH_7.2*,OpenSSH_7.3*,OpenSSH_7.4*,OpenSSH_7.5*,OpenSSH_7.6*,OpenSSH_7.7* compat 0x04000002
    <— debug1: Authenticating to mysite.com as ‘user
    <— debug1: SSH2_MSG_KEXINIT sent
    <— debug1: SSH2_MSG_KEXINIT received
    <— debug1: kex: algorithm: curve25519-sha256
    <— debug1: kex: host key algorithm: ecdsa-sha2-nistp256
    <— debug1: kex: server->client cipher: mysite.com MAC: compression: none
    <— debug1: kex: client->server cipher: mysite.com MAC: compression: none
    <— debug1: expecting SSH2_MSG_KEX_ECDH_REPLY
    <— debug1: Server host key: ecdsa-sha2-nistp256 SHA256:FI1HsDT8Exu55VGrkwyUpoIToPckiHLI3/MpDl7bims
    <— debug1: Host ‘mysite.com’ is known and matches the ECDSA host key.
    <— debug1: Found key in /Users/user/.ssh/known_hosts:35
    <— debug1: rekey after 134217728 blocks
    <— debug1: SSH2_MSG_NEWKEYS sent
    <— debug1: expecting SSH2_MSG_NEWKEYS
    <— debug1: SSH2_MSG_NEWKEYS received
    <— debug1: rekey after 134217728 blocks
    <— debug1: SSH2_MSG_EXT_INFO received
    <— debug1: kex_input_ext_info: server-sig-algs=<rsa-sha2-256,rsa-sha2-512>
    <— debug1: SSH2_MSG_SERVICE_ACCEPT received
    <— debug1: Authentications that can continue: publickey,gssapi-keyex,gssapi-with-mic
    <— debug1: Next authentication method: publickey
    <— debug1: Trying private key: /Users/user/.ssh/mysite.com
    <— Load key “/Users/user/.ssh/mysite.com”: invalid format
    <— debug1: No more authentication methods to try.
    <— user****mysite.com Permission denied (publickey,gssapi-keyex,gssapi-with-mic).
    **** Peer closed connection
    **** user****mysite.com Permission denied (publickey,gssapi-keyex,gssapi-with-mic).
    ---- Disconnecting
    ls' at 0 [**user****mysite.com** Permission denied (publickey,ls’ at 0 ---- Running connect program (ssh -a -x -v -i /Users/user/.ssh/mysite.com -s -l user mysite.com sftp)
    —> sending a packet, length=5, type=1(INIT), id=0
    <— OpenSSH_7.8p1, LibreSSL 2.6.2
    <— debug1: Reading configuration data /etc/ssh/ssh_config
    <— debug1: /etc/ssh/ssh_config line 48: Applying options for *
    <— debug1: Connecting to mysite.com port 22.
    <— debug1: Connection established.
    <— debug1: identity file /Users/user/.ssh/mysite.com type -1
    <— debug1: identity file /Users/user/.ssh/mysite.com type -1
    <— debug1: Local version string SSH-2.0-OpenSSH_7.8
    <— debug1: Remote protocol version 2.0, remote software version OpenSSH_7.4
    <— debug1: match: OpenSSH_7.4 pat OpenSSH_7.0*,OpenSSH_7.1*,OpenSSH_7.2*,OpenSSH_7.3*,OpenSSH_7.4*,OpenSSH_7.5*,OpenSSH_7.6*,OpenSSH_7.7* compat 0x04000002
    <— debug1: Authenticating to mysite.com as ‘user
    <— debug1: SSH2_MSG_KEXINIT sent
    <— debug1: SSH2_MSG_KEXINIT received
    <— debug1: kex: algorithm: curve25519-sha256
    <— debug1: kex: host key algorithm: ecdsa-sha2-nistp256
    <— debug1: kex: server->client cipher: mysite.com MAC: compression: none
    <— debug1: kex: client->server cipher: mysite.com MAC: compression: none
    <— debug1: expecting SSH2_MSG_KEX_ECDH_REPLY
    <— debug1: Server host key: ecdsa-sha2-nistp256 SHA256:FI1HsDT8Exu55VGrkwyUpoIToPckiHLI3/MpDl7bims
    <— debug1: Host ‘mysite.com’ is known and matches the ECDSA host key.
    <— debug1: Found key in /Users/user/.ssh/known_hosts:35
    <— debug1: rekey after 134217728 blocks
    <— debug1: SSH2_MSG_NEWKEYS sent
    <— debug1: expecting SSH2_MSG_NEWKEYS
    <— debug1: SSH2_MSG_NEWKEYS received
    <— debug1: rekey after 134217728 blocks
    <— debug1: SSH2_MSG_EXT_INFO received
    <— debug1: kex_input_ext_info: server-sig-algs=<rsa-sha2-256,rsa-sha2-512>
    <— debug1: SSH2_MSG_SERVICE_ACCEPT received
    <— debug1: Authentications that can continue: publickey,gssapi-keyex,gssapi-with-mic
    <— debug1: Next authentication method: publickey
    <— debug1: Trying private key: /Users/user/.ssh/mysite.com
    <— Load key “/Users/user/.ssh/mysite.com”: invalid format
    <— debug1: No more authentication methods to try.
    <— user****mysite.com Permission denied (publickey,gssapi-keyex,gssapi-with-mic).
    **** Peer closed connection
    **** user****mysite.com Permission denied (publickey,gssapi-keyex,gssapi-with-mic).
    ---- Disconnecting
    ls: Fatal error: max-retries exceeded (user****mysite.com Permission denied (publickey,gssapi-keyex,gssapi-with-mic).)

Still looks like a key issue and wondering if its password for key and password for user being different.

All the best,
Brian

#7

Again no expert but if you have changed permissions to 444 that may be blocking the key upload. otherwise to he honest, not a clue!

#8

last minute thought, may be way of the mark here but try adding the key file to the sever manually and setting it at 444

#9

I see that the key is in wrong format…

#10

Hi George, that’s interesting as it’s the same key file I use for FIlezilla. Brian, I will try your suggestion too.

All the best,
Brian

#11

Hello George,
It seems that Filezilla supports the *.ppk file fine but Wappler needs something different. Could you tell me which format you would be expecting please and I’ll convert the ppk and retry.

@brian - I looked up the file permissions and it seems that 400 should be used.

Thanks and best regards,
Brian

#12

Wappler uses LFTP as underlying FTP command that uses on its turn OpenSSH for security and key handling.

It doesn’t understand PPK key files as those are from winPutty but you can convert them, see:

#13

Hello George,

Good morning. I successfully changed the format and was able to connect :slight_smile: If anyone else has the same issue I used the following command ‘puttygen private_key.ppk -O private-openssh -o private_key’

One issue I did find was that my private keys have different passwords to my sFTP passwords. When connecting in Wappler, you only have the option of entering one password for the sFTP account. The only way to negate this is to either have no password for your key or have the same password for key and sFTP account. I chose the latter and was connected.

All the best,
Brian

1 Like