Collections missing in Data formatter - NodeJS

Wappler Version : 3.9.7
Operating System : Windows 10 pro
Server Model: NodeJS
Database Type: MariaDB
Hosting Type: Linode

Expected behavior

“Collections” should be displayed in data formatter like explained here: Wappler Documentation - Show Total Number of Records from a Query

Actual behavior

It’s not displayed at all, but I can use it by entering the code manually in the Code view, like count() for example.

How to reproduce

Follow the tutorial mentionned above and check if you see “Collections”.

What data type are you trying to apply the collections on?

Hey @Teodor,
I have a list of comments in my Database and I just created a server action to display them all on my page.
Sorry I shared the wrong documentation on my post, I followed this one and “Collections” is not showing: Wappler Documentation - Show Total Number of Records from a Query

Can you show some screenshots of your steps?

Here you Go @Teodor, I’ve recorded it to show you :slight_smile:

That’s strange, your query is not being recognized as an array. Just tested the same and it seems to work fine:

Can you maybe try recreating the server action?

Just tried again and same problem.
Actually I have a few pages showing a list of records and they are all recognized as Text and not Array.
That said, if I write “count()” directly in my code, it really displays the number of records…

@Teodor I’ve just created a new DB table to try it again from “almost” scratch, and same issue:

I’ve tried with a completly new project and it was working perfectly though… :thinking:

We are having similar issues with nested queries but will start a new thread. Am certain we could select the nested repeats as arrays before and now they don’t appear as an array anymore… If we manipulate by hand everything is fine and displays as normal, ie show/hide/format etc. Very strange. Across the board with Node and PHP server types…

Any update/response on this issue please?

Is this issue resolved in 4.0.0 Beta versions? Happening with multiple queries, nested queries, real pain in the backside! I don’t want to throw a load of views together to skirt this issue… Can see clearly in the Actions that type is array so why do they show as Text when used within a page?

If you just change the type to array as Teodor indicates above, you should have no problems:

Hi @George thanks for the out of hours reply I really appreciate it. Unfortunately that does not work as it the fields for the formatting become blank and as soon as you select the array it reverts back to text. For now am simply adding [0] to get around it. Is this issue fixed in 4.** by any chance?

Fixed in Wappler 4 beta 8

1 Like

This topic was automatically closed after 45 hours. New replies are no longer allowed.