Clicking on data binding doesn't display Expression

If I click on a Data Binding (in the Design View area) it is not selected in the Properties Panel, but if selected in Code View it is…?

This is a site developed in DW with DMX Extensions and being worked upon within Wappler…

Probably missing something so please don’t discount user error here :smiley:

Am I being a Muppet once again?

Video Attached below:

2018-11-15_21-32-42.mp4 (3.9 MB)

Nada…? What if I mention API… API.


hmmm API, API - iam iam :slight_smile:

I watched the video before but it wasn’t really clear what you mean.

Design view selections reflect directly in code view and in the app structure panel, but only if they are whole elements.

If you are selecting a text - you can double click to go to inline text mode and use the data binding there from the toolbar. Or go to code view and select it and then go from the properties panel …

Thanks George,
Reminds me of an IRC bot API API API! :smiley:


In the video I’m clicking on inserted Bindings but it does not bring up the Data Bindings panel most of the time. Especially if there is any type of text formatting such as Strong etc. If selected in Code view it displays the Data Bindings Panel. There doesn’t seem to be any reason to it. Some items show the panel others don’t. I know it’s not Dreamweaver but the ability to just click anywhere and insert a Data Binding or click on a Data Binding and be able to edit it is sorely missed (well more hit and miss). Slows down work-flow a lot for me as I never really know what it’s going to do. I’ve yet to build a site in full using Wappler so am learning slowly here but some things just don’t seem to work for me. As I say I’m learning slowly here…

hmm I see - maybe @patrick can check the design view data bindings…

1 Like

Thank you kindly George I really appreciate that. And thank you too Patrick!

Still the same issue with 1.61


Same issue with 1.62 will submit a bug report…