Can't get table sorting sorted out

I tried playing with the table sorting and it appears to be easy enough after getting some hints from the DMX Extension videos. But I can’t seem to get it to work. It will only sort in ascending order and only one column regardless which header I click on.

https://dashboard.wlstudiotheatre.ca/test.php

I can confirm this, also could not get Table Sorting to work, and I chatted to Brad about this quite extensively, he was also attempting to do this from the video instructions https://www.youtube.com/watch?v=69sONTE_cRA

Hello guys,
this will be fixed in the next update.

2 Likes

So Paul and I weren't completely off our rockers then. :wink:

There was a small bug in the query builder :slight_smile: we fixed it already and the fix will be included in this week’s update.

1 Like

That is certainly good to know, thanks for all the help testing this with me Brad.

Is it me or is this still not working. I still cant get headers to sort at all. The url changes to show sort=CustomerID&dir=asc
or
sort=CustomerID&dir=desc

but the actual table data does not change? Don’t want to spend any more time on this if it is a bug

I don’t think it is just you. I have the same issue. Shows the sorting in the URL but doesn’t sort anything.

https://dashboard.wlstudiotheatre.ca/test.php

I’ve tried sorting from a select menu, using sort conditions in Server Connect - and it’s working fine.

I haven’t experimented much with the table generator and sorting, but I think it works alright. I sometimes find it helpful to have a sample to look at, so I got copied the code between the tags from here:
https://showcase.dmxzone.com/BS4TableUsers/
… into a new page in Wapper (with the relevant frameworks included),
… using this data:
https://showcase.dmxzone.com/BS4TableUsers/data.json
… and it worked.

One thing that is required is that you include in the select query all the columns that you want sorting on. So not just * but the individual column names

1 Like

Thanks Tom but still cant see the problem.
I am selecting only the sortable fields from the table so they are specifically named in the query.
I have deleted it all and redone it following documentation exactly but still no sorting. Anyone able to look at the code and see if they can spot the problem? No doubt it is something very simple but spent a full day on this and on the verge of firing up DW again and giving up

http://dev.findmystudentdigs.co.uk/admin/listcustomers.php

You haven’t bound the serverconnect query to the filters, so it is not using the sorting.

See arround 3:40 at the video:

Thanks George, it’s obvious once you know. Working now

1 Like

Btw you are missing somehow the jQuery on your page. It is required for Bootstrap

Thanks, added it in, ironically everything was working

Well all our App Connect stuff - is already jQuery independent and does not use it. But some Bootstrap 4 components still require it.

This solved it. Works wonderfully! Thank you!

1 Like