Cant get Data/records to show in content pages

Should i be seeing data/records on the content pages themselves when i open to edit? becuase i don’t. In main page they display fine.



Hey Johnny,

Make sure app connect is on (blue)

And if the server connect page is protected, you’ll need to get logged in first within the editor.


I had secured the mainpage and logged in but i removed everything now and recreated the Content page and still no data on it. Just the blank box that says Card Body. Makes it difficult to edit…

What happens if you turn off App Connect Mode?


I had the same issue and reported it here Updated 2.3.4 and parts of design view no longer show

All OK when clicking the Lightning Bolt


Disabling the bolt shows me the code. I THINK it was working yesterday.

I have access to the databindings of head page but results don’t show

Sorry to bring it up again but i didn’t get an exact answer and i now have to decide if i go down the SPA route for my dashboard.

My Content Page doesn’t show records. Header Page w/content page embedded works fine.

Since i cannot see what the content page will looks like with records, i don’t feel i can make changes to it.

Can anyone confirm this behaviour? is it by design? I THINK it was working two versions ago but i am not sure. (i might have tested a static page.)

Hello @Kattouf
If the data source, i.e. your server action is on the main page you won’t see the data rendered on the content pages, when you open them separately.

If this data source is used only on this page, you can just move it to the content page - then you will see the data.

1 Like

Thanks. Yes i tested that and it worked. Is this what everyone does?

Ah so i guess it is best to first create a blank Content page and build it separately. Instead of bulding it in the header page and moving the actions later.
I’ll keep that in mind.