Cannot deploy to AWS after 3.7.0 update numerous errors in Wappler console relating to python and sqllite

======== TEMPLATE BUG FORM ========

Wappler Version : 3.7.0
Operating System : Mac
Server Model: NodeJS
Database Type: MySQL8
Hosting Type: AWS - Docker

Expected behavior

What do you think should happen?

I should be able to deploy to AWS as per normal.

Actual behavior

What actually happens?

I get the following errors in the console of Wappler:

> sqlite3@5.0.1 install /opt/node_app/node_modules/sqlite3
> node-pre-gyp install --fallback-to-build

**node-pre-gyp WARN Using request for node-pre-gyp https download **
**node-pre-gyp WARN Tried to download(403): **
**node-pre-gyp WARN Pre-built binaries not found for sqlite3@5.0.1 and node@12.18.0 (node-v72 ABI, glibc) (falling back to source compile with node-gyp) **
**gyp ERR! find Python **
gyp ERR! find Python Python is not set from command line or npm configuration
gyp ERR! find Python Python is not set from environment variable PYTHON
gyp ERR! find Python checking if “python” can be used
gyp ERR! find Python - “python” is not in PATH or produced an error
gyp ERR! find Python checking if “python2” can be used
gyp ERR! find Python - “python2” is not in PATH or produced an error
gyp ERR! find Python checking if “python3” can be used
gyp ERR! find Python - “python3” is not in PATH or produced an error
**gyp ERR! find Python **
**gyp ERR! find Python ************************************************************
gyp ERR! find Python You need to install the latest version of Python.
gyp ERR! find Python Node-gyp should be able to find and use Python. If not,
gyp ERR! find Python you can try one of the following options:
gyp ERR! find Python - Use the switch --python="/path/to/pythonexecutable"
gyp ERR! find Python (accepted by both node-gyp and npm)
gyp ERR! find Python - Set the environment variable PYTHON
gyp ERR! find Python - Set the npm configuration variable python:
gyp ERR! find Python npm config set python "/path/to/pythonexecutable"
gyp ERR! find Python For more information consult the documentation at:
gyp ERR! find Python
**gyp ERR! find Python ************************************************************
**gyp ERR! find Python **
**gyp ERR! configure error **
gyp ERR! stack Error: Could not find any Python installation to use
gyp ERR! stack at (/usr/local/lib/node_modules/npm/node_modules/node-gyp/lib/find-python.js:307:47)
gyp ERR! stack at PythonFinder.runChecks (/usr/local/lib/node_modules/npm/node_modules/node-gyp/lib/find-python.js:136:21)
gyp ERR! stack at PythonFinder. (/usr/local/lib/node_modules/npm/node_modules/node-gyp/lib/find-python.js:179:16)
gyp ERR! stack at PythonFinder.execFileCallback (/usr/local/lib/node_modules/npm/node_modules/node-gyp/lib/find-python.js:271:16)
gyp ERR! stack at exithandler (child_process.js:310:5)
gyp ERR! stack at ChildProcess.errorhandler (child_process.js:322:5)
gyp ERR! stack at ChildProcess.emit (events.js:315:20)
gyp ERR! stack at Process.ChildProcess._handle.onexit (internal/child_process.js:273:12)
gyp ERR! stack at onErrorNT (internal/child_process.js:469:16)
gyp ERR! stack at processTicksAndRejections (internal/process/task_queues.js:84:21)
gyp ERR! System Linux 5.3.0-1032-aws
gyp ERR! command “/usr/local/bin/node” “/usr/local/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js” “configure” “–fallback-to-build” “–module=/opt/node_app/node_modules/sqlite3/lib/binding/napi-v6-linux-x64/node_sqlite3.node” “–module_name=node_sqlite3” “–module_path=/opt/node_app/node_modules/sqlite3/lib/binding/napi-v6-linux-x64” “–napi_version=6” “–node_abi_napi=napi” “–napi_build_version=6” "–node_napi_label=napi-v6"
gyp ERR! cwd /opt/node_app/node_modules/sqlite3
gyp ERR! node -v v12.18.0
gyp ERR! node-gyp -v v5.1.0
**gyp ERR! not ok **
**node-pre-gyp ERR! build error **
node-pre-gyp ERR! stack Error: Failed to execute ‘/usr/local/bin/node /usr/local/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js configure --fallback-to-build --module=/opt/node_app/node_modules/sqlite3/lib/binding/napi-v6-linux-x64/node_sqlite3.node --module_name=node_sqlite3 --module_path=/opt/node_app/node_modules/sqlite3/lib/binding/napi-v6-linux-x64 --napi_version=6 --node_abi_napi=napi --napi_build_version=6 --node_napi_label=napi-v6’ (1)
node-pre-gyp ERR! stack at ChildProcess. (/opt/node_app/node_modules/node-pre-gyp/lib/util/compile.js:83:29)
node-pre-gyp ERR! stack at ChildProcess.emit (events.js:315:20)
node-pre-gyp ERR! stack at maybeClose (internal/child_process.js:1021:16)
node-pre-gyp ERR! stack at Process.ChildProcess._handle.onexit (internal/child_process.js:286:5)
node-pre-gyp ERR! System Linux 5.3.0-1032-aws
node-pre-gyp ERR! command “/usr/local/bin/node” “/opt/node_app/node_modules/.bin/node-pre-gyp” “install” "–fallback-to-build"
node-pre-gyp ERR! cwd /opt/node_app/node_modules/sqlite3
node-pre-gyp ERR! node -v v12.18.0
node-pre-gyp ERR! node-pre-gyp -v v0.11.0
**node-pre-gyp ERR! not ok **
Failed to execute ‘/usr/local/bin/node /usr/local/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js configure --fallback-to-build --module=/opt/node_app/node_modules/sqlite3/lib/binding/napi-v6-linux-x64/node_sqlite3.node --module_name=node_sqlite3 --module_path=/opt/node_app/node_modules/sqlite3/lib/binding/napi-v6-linux-x64 --napi_version=6 --node_abi_napi=napi --napi_build_version=6 --node_napi_label=napi-v6’ (1)
npm ERR! errno 1
npm ERR! sqlite3@5.0.1 install: node-pre-gyp install --fallback-to-build
npm ERR! Exit status 1
**npm ERR! **
npm ERR! Failed at the sqlite3@5.0.1 install script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR! /root/.npm/_logs/2021-01-11T00_06_02_543Z-debug.log
ERROR: Service ‘web’ failed to build : The command ‘/bin/sh -c npm install --no-optional --production’ returned a non-zero code: 1
Error Launching Services!

@George & @Teodor - tagging you as I have now tested this in my other project within Wappler (I have two, both the exact same setup and both failed when deploying to AWS).

This is a pretty critical issue if deployment is now not possible since 3.7.0 update.

Guys, I’ve also now just tried a complete reboot of my mac, Docker and Wappler - still the same issue. Deploying to local docker works fine, but it fails when trying to deploy to Docker in AWS. Zero issues prior to 3.7.0 update.

This is actually not a Wappler issue but an issue with the SQLite version for node.

They just released a new version and seems didn’t publish all the needed binaries.

There is an issue there, hope they will fix it soon:

As you are probably not using SQlite at all, you can just edit your package.json and delete the SQLite dependency line:

"sqlite3": "^5.0.0",

and then publish your project.

Do note that on Wappler project switch or reopen it will be auto added again, we will see if we can improve that in the next update.

Thank you for the workaround @George - I’ll try this in the morning. I note it does also error not just on SQLite (which I’m not using) but has some python errors too- is this related to the same issue?

Yes python is a side effect - because the SQLite binary is missing - it tries to compile SQLite from source and it needs python for that …

1 Like

Thank you George.