Bug Report from oeweb #2020-1-13_10-35-58

OS info

  • Operating System : Windows 10.0.18362
  • Wappler Version : 2.5.4

Problem description

The server connects are no longer working on the new update whereas it worked before I updated which was version 2.5.0.

Steps to reproduce

  1. You just have to load anything and it doesn’t work but it did in my previous version

Your explanation is unclear.
Can you please explain your issue a little more detailed?

I was on version 2.5.0 and I was able to use the server connects fine on my mobile project everything loaded as it should but yesterday I updated to the newest version 2.5.4 and nothing is loading, the loads still work on the app that I built it just doesn’t show anymore on wappler itself.

Can you post a screenshot of the whole Wappler window also including the “things” that don’t load any longer?
Also - what Wappler license are you using, and which account it is assigned to (not to this one obviously)?

Sorry but what exactly on your screenshot is not loading? What should i look at?

first image show the profile button I click it and it goes to the second image and 3rd image shows the loads that are not working whereas in the previous version it didn’t do this but this is just an example all of them don’t work. It is not a huge problem but it is hard to make sure that functions working on wappler rather than having to build it ever time I want to test something out

I see error statuses of 401 - unauthorized. Does your app require log in in order to load the data?
Probably you are using security restrict in the server connect and it requires you to log in first… that’s why you see this.

Also: Which account are you using Wappler with, as it’s not the one you are posting from?

Do you think it has something to do with this

my chrome is using my google account I set that up first before I downloaded and logged on with wappler I have a new PC that I got a month ago so I set it up like that

No, i already explained you what the issue looks like to me:

Yes but all this worked before in a previous version I haven’t changed anything about it only now that these statuses of 401 are showing up

There are quite a few discussions on this topic:

probably the last time you checked this you were logged in, or the restriction was not applied yet.

I know how restrictions work but the restrictions were already set up way before and all the versions until this version it worked fine is there something new in the update that changes the restrictions behavior?

No, there is nothing new, just turn on the preview mode and log in - you will see your data.
There is no way to preview data, which requires you to be logged in, same as in your browser.