Browser cache issue

Problem: On my production server, new data is inserted into the database, however this new data is not displayed on the page after insert, update, etc. until I do one of the following to disable Browser Cache:

  1. Browser Empty Cache and Hard Reload
  2. Disable browser caching within browser

Troubleshooting steps completed:

  • Verified no cache on hosting server.
  • I’ve tested this issue with both PHP and NodeJs projects developed with wappler, this issue is consistent in both projects.
  • I’ve also tried the suggestion from @Hyperbytes to issue a disable cache in the meta data, this only works for the first page load but not additional page loads.
  • Wrote non-wappler generated code and/or DB Connections… issue does not exist.

Therefore, my guess is something within the dmxLibraries is creating this loading/caching issue?
Any insight would be greatly appreciated.
Thank you

There shouldn’t be anything in Wappler that controls caching. That’s all done locally.

Have you tried reloading the data on form success?

Are you sure you reload your server action displaying the data on the page on insert success event?

@brad @Teodor yes, i’ve attempted to reload data on success where applicable. I’ve also run into workflows where the reload is not available after insert/update. Ex. Data insert form, user click Save & New Submit button, new insert page inputs data, submit success tells API to refresh asset tag field previously input, API doesn’t increment field. Ex. 2: Data insert/update, user click Save which returns user to list table of input data, this API is not available on data insert/udpate.

Pretty sure its not a cache issue, but a configuration issue.
We have worked on numerous projects on various server models, and this has never been an issue.
Add/update something using a server connect or server connect form, and on success dynamic event, reload the SC used for binding list data.

Worst case scenario, its your production server that is the cause. Happen to us once where the remote server was not talking to the DB as expected - a restart of the server solved it then.

There must be something on your server caching things really hard then. Are you maybe using some cloudflare features like caching?

Also, make sure you are not caching the server action results:

Following on from Teodors caching suggestion, i have to agree this is a likely cause. Many providers are integrating done sort of edge caching on their servers which would potentially lead to issues like this.
Who is hosting the site?

@sid Thank you, this was it, server reboot cleared a stuck process which was a pending OS update, ran the OS update, now page data response is as expected.

1 Like